2

Whenever entering the date e.g. day-month-year, it automatically changes to month-day-year. I went into format>number>more formats>more date and time formats, and I changed it to day-month-year. And again, when entering day-month-year e.g. 18-4-2014, it changes it to 4-18-2014, but when I click on the date, it shows as 18/4/2014 next to fx above the page.

So it looks like Google Spreadsheet is messing up. How to fix this?

2
  • 1
    You could put your comment as answer, it fixed my problem, thanks! If you put it as answer, I can mark it as answered. Commented Apr 18, 2014 at 21:00
  • 2
    If I enter 18-4-2014 it leaves it as 18-4-2014, but if I enter 5-2-2014, it changes it to 2-5-2014.. But now, the problem is solved by using Netherlands as locale. I am using the new spreadsheet Commented Apr 18, 2014 at 21:11

1 Answer 1

2

The solution is to set the correct Local under the Spreadsheet's settings ("This affects formatting defaults, such as currency."). So if you want US.locale style (MM-DD-YYYY), then choose US.Locale. If you are in a different locale and want formatting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.