I keep getting emails from YouTube telling me about random strangers supposedly sharing videos with me. I do not know these people and they are unlikely sharing videos with me. It seems more like YouTube is either sending me links to related videos or doing some sort of auto-send-to-all-commenters nonsense. They are definitely coming from “mr.google” :-P as you can see from the header of the latest message (listing 1).

There don’t seem to be any settings to not receive these spams; the closest I can find is a setting which (for some reason) lumps shared videos and private messages together (figure 1). Regardless, I have that turned off, and yet I still get these blasted shared-video spams. (Not that I wanted it at all, but in Google+, I have already set it so that only I can send myself email.)

How can I get YouTube to knock it off (short of deleting my Google account altogether)?

Listing 1: Header of recent shared-video message showing Google/YouTube as the source.

Delivered-To: <ME>
Received: by with SMTP id ph2csp69733pac;
                Fri, 21 Mar 2014 20:17:34 -0700 (PDT)
Return-Path: <3zQAtUwcLCCILMPCNJWWMSRS9C.AMKKU8JQFCPEK8GJ.AMK@youtube.bounces.google.com>
Received-SPF: pass (google.com: domain of 3zQAtUwcLCCILMPCNJWWMSRS9C.AMKKU8JQFCPEK8GJ.AMK@youtube.bounces.google.com designates as permitted sender) client-ip=
Authentication-Results: mr.google.com;
             spf=pass (google.com: domain of 3zQAtUwcLCCILMPCNJWWMSRS9C.AMKKU8JQFCPEK8GJ.AMK@youtube.bounces.google.com designates as permitted sender) smtp.mail=3zQAtUwcLCCILMPCNJWWMSRS9C.AMKKU8JQFCPEK8GJ.AMK@youtube.bounces.google.com;
             dkim=pass [email protected]
X-Received: from mr.google.com ([])
                by with SMTP id a6mr3286828qaa.6.1395458254849 (num_hops = 1);
                Fri, 21 Mar 2014 20:17:34 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
                d=youtube.com; s=20120806;
X-Received: by with SMTP id a6mr2117396qaa.6.1395458253938;
                Fri, 21 Mar 2014 20:17:33 -0700 (PDT)
Content-Type: multipart/alternative; boundary="===============1551076356=="
MIME-Version: 1.0
X-No-Auto-Attachment: 1
Subject: =?iso-8859-1?q?Justice_sent_you_a_video=3A_=225x5__Rubik=27s_cube_former?=
From: YouTube <[email protected]>
To: <ME>
Message-ID: <[email protected]>
Date: Fri, 21 Mar 2014 20:17:33 -0700 (PDT)

Figure 1: Screenshot of only setting that mentions shared-video (lumped together with private messages)

Screenshot of only setting that mentions shared-video (lumped together with private messages)

  • 1
    Are you sure the emails are really coming from YouTube and are not just phishing spam mail? Try looking at the header of one or two, see if there's a different origin. Apr 21, 2014 at 4:56
  • Would you mind sharing a screenshot of one of these mails? You can blur out your mail and other sensitive stuff. Apr 21, 2014 at 14:34
  • Yes, they’re definitely from YouTube/Google. I’ve added the header of the latest message.
    – Synetech
    Apr 21, 2014 at 17:07
  • Is there anything pertinent if you follow the 'Google+ notification settings' link? Apr 21, 2014 at 18:15
  • I found a list of so-called YouTube “contacts” at youtube.com/address_book, except I never added any of them (as seen in my contact-notification page at youtube.com/inbox#invites/1). Random strangers added me as contacts (for some reason) and so were automatically granted permission to spam me. That they’re strangers makes me wonder if they’re spam accounts. I could delete them, but that won’t stop new ones. It looks like YouTube allows anyone to spam anyone by simply adding them as a contact even if they don’t reciprocate, so you can add a celeb., ex, etc., then spam the hell out of them.
    – Synetech
    Apr 26, 2014 at 16:30

3 Answers 3


If you're using Gmail, you can create a filter so these messages don't hit your inbox. If you don't want any emails from YouTube, you can search for it and then click Create filter. You can add additional criteria on the next page, confirming the results before creating the filter.


Make sure you are logged into your google account and go to youtube.com. Next to the "Upload" button on the top dashboard, click on the dropdown settings gear and select "Youtube settings". In the side menu under "Account Settings" select the "Privacy" option.

Under "Search and Contacts", Allow only my contacts to send me messages and share videos is unchecked by default, meaning anyone can share video with you. Check it, and your problems should go away.

  • I’ve already done that (I’ve checked all of the keep…private) boxes. I attempted to find a list of my YouTube contacts to see who’s in it, but couldn’t find one, though I did find a list notifications of other people who added me as contacts (I don’t know any of them). It looks like Google/YouTube has a (purposeful‽) bug which allows anyone to send junk to anyone by simply adding them as a contact even if the recipient does not reciprocate. I can’t find a way to remove these people (probably because I never added them). (Also, I want to allow private messages, just not shared videos.)
    – Synetech
    Apr 26, 2014 at 16:20

I've had such a problem. I created a filter in Gmail like this:

from:([email protected]) subject:(sent you)

and checked Delete to trash as an action.

So normal mail from YouTube will pass and the spam will go to trash.

Not the answer you're looking for? Browse other questions tagged or ask your own question.