1

I changed my account settings to reflect my newly sent mail with my name, and all my outgoing mail reflects this change. However, when people reply to messages, the message is addressed to the old send name.

For example, when I send a message with the new name it shows : From: Mary123 <123@gmail.com>, however when I receive a reply from the person I sent the message to it shows the old name: To: 123Mary<123@gmail.com>. How can I fix this with the mail I receive?

2

First, make sure your account is indeed set to display the correct name.

Visit this page to check your settings in GMail

http://www.google.com/settings/personalinfo

Make sure the name and nicknames are correct.

Second, make sure the emails you are looking at are indeed replies to NEW mail you sent.

If someone replies to an old email, OR they create a new message to you from an pre-existing contact entry, then the chances are they will still have the old name.

Try asking that person to update their contact list if this is the case.

  • 1
    The second point here is almost certainly what's causing the issue. – ale May 15 '14 at 2:07
1

In Gmail settings you can go to the Accounts tab (https://mail.google.com/mail/u/0/#settings/accounts if you only have 1 user). In the "Send Mail As" section, click on the "edit info" link for the name you want to change and there you go.

  • This solved my problem. This is a bug in GMAIL, it doesn't update the "Send mail as" setting when the account's name changes, even when it was never changed manually. – Crouching Kitten Feb 8 '17 at 9:53
0

I'm having the same problem. Here is how I solved it:

I changed the original name from "Bob" to "Steve". Nothing happened but when I went to the "About me" page it reflected "Steve".

So I changed it from "Steve" to "Stephen" and now it is "fixed" but shows "Steve" on all my emails, It's not perfect but at least it shows my name!

0

In Gmail, go to settings, then accounts and Import, Change your send email as:.

-1

Right there in your email, normal view, there's a tiny grey arrow next to your name, arrow is pointing down. Click on that, it takes you to 'Edit Contact Details', and there(!)... you can change your name. I took me a while to figure this out!

protected by Community Jan 5 '18 at 20:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.