10

The problem:

There are certain product pages (e.g.: film, videogames) that basing on your ip automatically redirect you to the locale of where you are living. This forces me to see only pages (and updates/feeds) in German, when I want the English ones.

No matter if I "like" the page on the redirected page or on the forced English page, I get the updates in my news feed from the German version :|


The question(s):

  • As a user of Facebook, is it possible and if yes, how (eg. with Facebook options, GreaseMonkey scripts) to avoid geo-ip redirection from pages?
  • Is it possible to receive the news feed in the desired language?

In the chat jonsca suggested me to have a look at this question from SU.SE: I know that a proxy might do the job, but sincerely it would be my last resort (right after stop caring about those pages).

  • ?brandloc=DISABLE doesn't appear to work anymore – Tobias Kienzler Jun 15 '15 at 6:10
4

Fortunately you can now simply click the three dots on the page in question and choose "Switch Region...".

switch region

| improve this answer | |
  • At least with facebook.com/Fallout it works (I chose the UK version to be sure, since US is "default" which sounds like something that might one day revert, e.g. to a Swiss German version once provided...) – Tobias Kienzler Jun 15 '15 at 6:40
0

The easiest way, in my opinion, would be to use a proxy server, preferably one with an app icon that allows you to connect/disconnect on demand. That way, you can decide which IP is represented to each page you browse. Simply select a server at the target country, and browse the content. The server will "think" you're in that country, and serve you local content.

Disconnect as needed, to get your local content.

| improve this answer | |
  • I wouldn't call that easier than using the fortunately provided setting to switch, but of course this solution works for the internet in general (except for services that started blocking proxy-providers as well) – Tobias Kienzler Mar 15 '16 at 6:44
0

Use the English pagename with /ncr after ("no country redirect"). Like this: /pagename/ncr. (The same as you do with Google).

| improve this answer | |
  • I'm afraid that switch doesn't work (anymore, at least) – Tobias Kienzler Jun 15 '15 at 6:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.