44

In most word processing applications, entering two sequential dashes is enough to create an em dash. Not in Google Documents:

two sequential dashes example

It'd be nice if those two hyphens joined together — wouldn't it?

(The em dash directly above was written using HTML: —.)

So how to create an em dash in Google Documents?

  • 3
    This question is actually (kind of) wrong – typing two hyphens typically gives an en dash, and em dashes are often created with three hyphens. Additionally, while spaces should be used around en dashes (e.g. my previous sentence), em dashes are used without spaces—like this. – Arthur2e5 May 18 '16 at 17:30
37

Actually, in Google Docs you can have it automatically replace the two dashes with the em dash while you type!

  1. Tools > Preferences...
  2. In 'Replace' type: -- (include space on each side)
  3. In 'With': Enter the em dash character*:
    • Windows: Hold Alt and enter 0151
    • Mac: Option + Shift + -

* as suggested by OnenOnlyWalter

Preferences Dialog

  • Unfortunately it seems like you need to put a space after for the conversion to happen. Also, if you immediately hit backspace to remove the space, it converts back to two dashes. – Muhd Aug 14 '16 at 20:31
  • The alt keystroke combination didn't work for me, but combining this answer with the one below about inserting special characters did the trick. – dolphus333 Feb 17 '18 at 1:05
  • This backspace and lose the em non-logic is still here and it is quite annoying. – Richard Griffiths Oct 6 '18 at 8:36
21

Answer by @SamtheBrand is correct, but there are also keyboard shortcuts to insert an em dash.

Windows: Hold Alt and enter 0151

Mac: Option + Shift + -

  • 2
    Alt+0150 and Option+- are for EN-dash (shorter one). For EM-dash (longer one): Alt+0151 in Windows and Option+Shift+- on a Mac. – ash108 May 10 '14 at 13:34
  • 2
    Ah, my mistake, you're right. Updated my answer for accuracy. Thanks! – OnenOnlyWalter May 14 '14 at 21:14
  • 2
    You have to enter the numbers on the numpad, at least on my computer; the regular number keys don't work. – Jim Stewart Oct 12 '16 at 10:34
11

Insert > Special Characters...

enter image description here

Make sure you're in "Punctuation" in the left menu, and "Dash/Connector" in the right menu.

enter image description here

The em dash is the third from farthest right option. Click it and hit insert.

1

One problem with the the first option (Tools, preferences) is that, supposedly, there should be no spaces before or after the m-dash, but the moment you enter a space after the dash thus inserted it reverts back to the two hyphens. The problem with the second option (Insert, Special characters) is "too many steps."

The workaround that works for me is to just type two hyphens, and when you are done with your document, do a Edit, Find and replace. Find: -- ; Replace with: alt+0151. Replace all.

Alternatively, if you have the preference already selected, you can do the same: at the end, find and replace all "— " (m-dash followed by space) with "—" (without the space).

1

if you do the replace -- with an em dash, and are having trouble because it requires a space afterwards, just do this. after you do the "--" and then press space, press these keys in this order "right arrow, left arrow, backspace." that should get rid of the space and keep the em dash. hope this helps.

1

Google Docs on a Mac:

  • option+hyphen = en-dash,
  • option+shift+hyphen = em-dash
0

On Mac, just hold fn + option + -

-1

Google Docs: option+hyphen, option+hyphen will make an em-dash.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.