1

I just created a complex form using Cognito Forms and when testing the form using the URL and the embed code, form data submits but nothing happens on the page. The confirmation message never appears and the URL never redirects (I have tried both options). Anyone else run into this and have a solution?

1

I am a developer for Cognito Forms. We recently released support for conditionally visible fields, sections, content, etc. based on custom calculations on forms. As part of this we also conditionally hide these fields when sending email notifications with submitted form data. Unfortunately there was a small bug related to conditionally hidden content fields, which your form uncovered (because it was quite complex!). So while the entries are being saved, the email notification is not being sent and the confirmation is not displayed. The fix is currently being tested and will be deployed soon. You can avoid the issue for now by not sending detailed email notifications.

Thanks for also submitting this as a bug report! Bug reports through our product are the appropriate way to report issues, as this site is intended as a forum to ask questions about how to use Cognito Forms and other web apps to solve problems.

  • 1
    @pnuts, thanks for asking! This issue was resolved back in May and I should have updated this answer accordingly. – Jamie Thomas Nov 21 '14 at 5:23
  • 1
    Incidentally, when we've reached out to a couple of users asking them to mark questions as answers they have had problems signing up correctly. It sounds like they just signed up after the fact with the same email address and ended up creating a new account not linked to the question. Also, one did not realize the checkmark was clickable and should be clicked to mark the answer as accepted. Not sure what can be done to help, but thought I should pass this on since we are generating a lot of first time users for StackExchange. – Jamie Thomas Nov 25 '14 at 1:25
  • 1
    @JamieThomas If you run into this situation, please ask the user to use the "Contact Us" link at the bottom of the page and have them include both userIDs in the request. Thanks for taking notice of this. As moderators, we can't do the merges ourselves, but the Community Managers are able to do them via that form. – jonsca Nov 26 '14 at 3:38
  • 1
    (To the flagger of the comment, I had to decline the flag to keep the comment in place. Sorry.) – jonsca Nov 26 '14 at 3:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.