1

I've got a document in Dropbox which I issue to several people, the document is often revised so I need people to have the most recent version.

What I normally do is email out the new PDF when there is a release, but recently I've been trying to share it via a Dropbox link, not sharing the file in Dropbox so it syncs to their machine, but giving them a link to view the file online.

I'd like them to be able to view the file in their browser rather than downloading it, that way they will always be seeing the most recent version.

When I share the link and view it in a private browser tab (so that I'm not logged in) my machine just defaults to downloading the PDF, any idea how I can set it so people can view it in their browser?

As an example I've shared a file via Dropbox here.

  • On my chrome I able to view even in icognito tab – Aminadav Glickshtein Jun 9 '14 at 20:08
  • Strange, the same seems to be working for me, I use Firefox as my default, it seems to be a browser issue – sam Jun 9 '14 at 20:15
  • It works for me (displays inline) in Firefox. I think it's just browser settings. – Icydog Jun 10 '14 at 1:46
  • With the links which are exhibiting the undesirable behaviour you described, ensure their URLs do not end with ?dl=1. That's the only thing I can think of other than it being caused by browser setting. – Spooky Jun 17 '14 at 22:34
1

It is a Firefox settings issue. For Firefox 31.4.0, open the Options Dialog Box and then select the Applications tab. In the Content Type column select Portable Document PDF and then choose the action you desire.

1

You may want to consider adding ?raw=1 to the end of the link—the browser will treat it as a direct link to the file and behave however the end user's system is configured to access that type of file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.