53

In a Google Docs document, I would like to be able to specify the page margins (File → Page Setup) in millimeters instead of inches.

Is it possible to switch between imperial and metric units?

4 Answers 4

23

Go to Settings → Document Settings on the top right of the page and change the language to English (UK).

Rulers and margins will now both be in centimetres (cm).

You may need to log out and sign back in before you see the changes take effect.

6
  • 1
    Changing language works but one should know that only new documents are affected.
    – user17159
    Feb 7, 2012 at 9:10
  • 13
    Google should really decouple the preferences system. I live in Denmark so I measure my using the metric system and use DKK as currency, but I still want my interface to be in US English. Feb 24, 2015 at 10:01
  • 8
    @grunwald2.0: In the new Google Docs, the account language affects the measuring system (located at myaccount.google.com/language). The document language can be set differently in "File → Language".
    – tanius
    Apr 7, 2015 at 13:38
  • 1
    !!! this means that this answer is no longer correct! :( !!! Jul 8, 2016 at 13:33
  • 5
    This no longer works. See the answer from tanius instead. Aug 9, 2016 at 15:41
49

Due to recent changes, the measuring system in Google Docs is now affected by your Google Account default language, not anymore by the document language. (Means, @Dominik's answer no longer works.)

More precisely it's the country sub-setting that influences the measuring system now. And Google artificially limits country options depending on the chosen language.

So:

  1. Go to myaccount.google.com/language. You can also reach it via the gear icon on the Google Drive or Google Docs main pages.

  2. Set the language to "English – United Kingdom". (If it's currently "English – United States", click the pen icon, then again "English", then "United Kingdom". Bit counterintuitive.)

  3. Reload your Google Docs document.

Voila: rulers and the "File → Page Setup… → Margins" settings are in centimeters now.

11
  • 9
    technically, this solves the problem of the OP, but it creates more. it is sad that Google took away the per-document setting. Jul 8, 2016 at 14:13
  • 16
    "the measuring system in Google Docs is now affected by your Google Account default language" This is what I call a design mistake.
    – Avatar
    Jul 28, 2016 at 11:56
  • 2
    This should now be marked as the correct answer as the previously correct answer no longer applies.
    – Luke
    Feb 27, 2017 at 1:00
  • 5
    NOTE: For anyone following this convoluted thread of changes it seems that the above mentioned fix works as a default for new documents, however there is now a setting for the document under File -> Language ... so it would seem they've listened, thank you Google! Aug 14, 2018 at 7:11
  • 10
    Wow. The fact the selection of units is hard-coded to language selection is pretty messed up. By switching from US English to UK English you may find many other side effects such as different spelling suggestions (enrol vs enroll, etc). It is crazy that google confuses language variant with which units you want to use. Fine heuristic for default values but nonsense for many users. It is like sites from some companies that won't let you switch to the english version because your geo-ip is currently Germany...so you must speak german...right?
    – mattpr
    Mar 14, 2019 at 8:58
8

This is not possible in the current version of Google Docs with "English (US)" regional settings. Until they change this you can convert millimeters to inches using this Google query:

<n>mm in inches

Or you could follow the tips in Dominiks answer, and change your language settings to "English (UK)".

2
  • 3
    A helpful workaround. However, the answer from Dominik no longer works. See the answer from tanius instead. Aug 9, 2016 at 15:40
  • there is no English UK language, only US
    – serge
    Apr 14, 2019 at 8:36
3

To change the margins one can use File --> Page Layout --> Margins but doing so does not (for me at 2018-10-18) offer a change of the unit-of-measure of the margins.

Earlier answers show that this is influenced by the user's language. (1) It used to be the language of the doc (2) That was changed to the user's Google Account's language.

Well; I have set both to US English and have closed and opened the document but to no avail -- it stays at cm for me.

Here, though, is a low tech remedy: There are 2.54 cm to the inch. There is 0.39 inch to the cm. If the unit-of-measure stays stubbornly at the one you don't want, apply a conversion to get the desired margin. For example, I needed to have all four margins set to 1 inch, so set the value to 2.54 cm for each of the four.

1
  • Forget any manual corverting. The change in the settings just successfully applied to my document as well to my overall gAccount. (US-eng inches >> UK-eng cm) Just reload your doc to get the settings applied. No doubt that the "simplification" was just stupid, from Google. :-/
    – Franta
    Mar 17, 2019 at 22:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.