0

One thing I find myself doing a lot is trying to navigate my e-mails using my keyboard. I have found the "caret" showing current focused e-mail, in Compact dark theme, is a blue indicator and that can be moved up and down using the keyboard. You can also use Enter to read the currently selected e-mail.

What bothers me is that Spacebar isn't used to select the currently focused e-mail. The Spacebar has more of a page down functionality. Nothing has annoyed me more than having to select a group of e-mails using my mousepad on my laptop; not to mention it is very inefficient to have to position the cursor precisely and hope you don't accidentally start dragging the item instead of selecting the check box.

**So my question is, how can I use my keyboard to select e-mails in Gmail -mail? **

Also, how I can delete the selected e-mails using my keyboard without using tab, if possible?

migrated from superuser.com Jul 23 '14 at 19:20

This question came from our site for computer enthusiasts and power users.

  • Have you enabled Keyboard Shortcuts via (in Gmail) Settings > General > Keyboard Shortcuts? – ṧнʊß May 29 '14 at 14:41
3

You need to manually enable Shortcuts in Gmail by:

  • Go to Settings > General > Keyboard Shortcuts and check 'Enable Keyboard Shortcuts'. Click Save

Now press ? on your keyboard to see a list of shortcuts you can use, or go here.

By default, press o or Enter to open the 'conversation' or email.

To use Space as the key to open emails:

  • Go to Settings > Labs > Custom Keyboard Shortcuts. Check enable.

  • Go to Settings (again) > Keyboard Shortcuts (it will be a new tab, near to 'Labs').

  • Go to 'Open conversation'. In the 'or' box, type in \32 which is the ASCII code for space bar.

Now, you will be able to open emails with space bar (it worked for me!).

  • I guess this is part one. What I think is happening is because I have a scroll bar on my page (using Google Chrome), when I hit Enter, Chrome is using that as page down functionality. Can you duplicate it this behavior too? – NETscape May 29 '14 at 16:18
  • @NETscape Strange... It doesn't happen for me... I use Google Chrome as well.... Could you try a different browser if you have access to one? I think space does normally move the page down, but that's not happening to me. I don't know why... – ṧнʊß May 29 '14 at 16:19
  • So I wanted to use spacebar to "Select conversation" not "Open conversation". Even when I don't have a scroll bar (only show 10 conversations at a time), and I use \32 for the "or" shortcut, hitting the spacebar doesn't select the convo :/. So I have: x "or" \32 – NETscape May 29 '14 at 16:23
  • @NETscape OK, I thought you wanted it for open. So you changed the \32 to Select Conversation? And you've made sure you can't scroll down (by having 10 emails on the page)? But the spacebar doesn't work? Do I understand you correctly? I can't understand why not! It works for me – ṧнʊß May 29 '14 at 16:25
  • Well if it works for you, I'll leave it as the answer. Using a Win 8 laptop if that means anything. I can deal with using the 'x' key – NETscape May 29 '14 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy