2

Since very recently I start getting popups when hovering English text showing me "Original text" as if it was translated. However, the original was in English, so this makes no sense!

What is worse, the feature remains enabled in Email Composer, making it even more of annoyance.

Any insight of what is going on here and how to solve it?

1
  • Any luck with solving this so far? Got the same issue with my Gmail. Apr 1 '16 at 20:06
1

This is the "offer to translate" feature in Chrome browser. Many people do not like the popups. The simplest solution is to disable translation in chrome://settings/languages

If you want to use translation but not the popups, one solution is to install the Google Translate extension from the Chrome Web Store. It should override Chrome's built-in translator.

2
  • I have unchecked "Offer to translate pages that aren't in a language you read" and removed all languages except English. Yet the hover effect remained, even on the control buttons! Sep 3 '14 at 15:58
  • None of this helps, unfortunately. May 16 '15 at 3:38
-1
<div id="google_translate_element">&#160;</div>
<script type="text/javascript">
function googleTranslateElementInit() {
    new google.translate.TranslateElement({ pageLanguage: 'en', includedLanguages: 'es' }, 'google_translate_element');

// This will find the pop up and remove it from the page
    var removePopup = document.getElementById('goog-gt-tt');
    removePopup.parentNode.removeChild(removePopup);
}
</script>

<script type="text/javascript" src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script> 
1
  • Is this the code to place somewhere? Apr 18 '15 at 1:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.