43

I'm in France and trying to use Google in English only. My Google settings are set to English everywhere:

enter image description here

I've also clicked on the link "use google.com" but when I do a search, it still shows some results in French, and I suspect the results are somehow tweaked for a French audience, which means some important English ones might be missing.

enter image description here

Is there any way to force it to really use only English (except for using a VPN or proxy server)?

16 Answers 16

16

I switched to Bing.com because of it. They have very convenient options as "Narrow by language" and "Narrow by region" right above search results. Also you can go to settings and set search results only in English and it really works as opposed to Google "fake" settings.

As for your question about Google I didn't find any working solution. All the other answers don't work for me either. Google kept showing me Russian results even when I was living in another country. I guess it uses OS language settings but I can't switch it because of stupid MS limitations on OEM OS. So I just began to use Bing as a workaround.

2
  • If it would MS then why Bing is showing correct results when it's MS search drive? Aug 30, 2016 at 9:26
  • 5
    This is actually very frustrating. They store a lot of information about you but cannot even remember preferred language. Accept language headers are totally ignored because Google knows better - you are in China then you must speak Chineese. At least they could store some cookie to allow user to override that. Jun 26, 2019 at 18:23
10

One way is to use Advanced Search: https://www.google.com/advanced_search

If you're logged in to Google, you can also change the preference "Currently showing search results in:" and set it to one or more languages

1
  • 2
    As far as I can tell the "Currently showing search results in" does not work whether you are logged in or not. I always have only english there and it still shows mostly french results
    – Kvothe
    Nov 10, 2020 at 16:39
8

One way is this:

https://encrypted.google.com/webhp?hl=en&gl=en

https://www.google.com/webhp?hl=en&gl=en

....................................................

4
  • The first one seems to work fine. The second not so much because it redirects to google.fr
    – laurent
    Dec 13, 2014 at 17:36
  • Both links do bit solve the problem for me, when I search for technical reference information (all of which is in English) I get mostly Japanese results, see screenshot i.stack.imgur.com/0h5Qo.png
    – nic
    Apr 13, 2018 at 2:54
  • I can not believe that google doesnt support &lang=en in the url Jun 16, 2020 at 13:56
  • Thanks, the top link is the only solution here that worked for me.
    – Kvothe
    Nov 10, 2020 at 16:41
5

Eventually I got it working on Firefox using this add-on: always ".com" - Google.com (in English).

1
  • 2
    Works great. A search for "BYO" was showing top 3 results in Japanese, now everything is in English.
    – nic
    Mar 8, 2016 at 9:54
4

I've made a custom search parameter, works well. Steps follow:

  1. Go to your Chrome settings
  2. Under Search, click on Manage search engines
  3. Scroll to the bottom, fill Add a new search engine and Keyword with whatever you want
  4. Fill the URL field with
    https://encrypted.google.com/webhp?hl=en&gl=en#safe=active&hl=en&gl=en&q=%s
  5. Press Done
  6. Go back to Manage search engines and make it your default

All default searches will be in encrypted EN from now on.

2
  • This absolutely does not work. Google search will switch to your local google domain based on IP you are using and it will show you results in IP specific language. Tthis Big Brother seems to know better what you need. This slowly makes me think about Bing.
    – Jeffz
    Aug 7, 2016 at 10:56
  • Doesn't filter completely, but I see more results in English with this. May 2, 2018 at 11:35
1

You can use a link such as this:

http://google.com/search?q=example&lr=lang_en

1

https://google.com/ncr

Once you visit this link, Google search localization, both region and language, will be disabled for all searches after that. I've read this somewhere on the internet long ago, don't remember where, it seems to be a "secret feature", but it works, I use it regularly. To reset, delete the web browser cookies.

PS: I don't log in with my Google account reguarly so I can't say how well it works while logged in, I think it does but not sure.

1
  • This seems to have worked for me, thanks for posting that link.
    – user218195
    Jan 26, 2019 at 10:23
0

I am from Tabriz Iran, I had just like your problem in search. You must go to setting in search menu under Google's search field, not setting menu on Chrome's menu. enter image description here

You can change only search results on this menu.

0

I only get search results in my native language if I am signed in Gmail. I signed out and all search results were back to English.

0

I had the same problem only with Google Quick Results, like when you are checking out a movie on Google after the search, on the right side.

THIS IS HOW I FIXED IT:

Short version:

I fixed it with changing language priorities (or removing the unwanted language) from Google Chrome (which doesn't even make sense). After saving, it worked through all browsers linked to my Google account.

Explanation (long version; optional to read):

Shocking, but it looks like Google guesses your preferred language from Accepted-Language header attached to all request responses by browser. And you can easily change that in Chrome settings (goes without saying that you should be logged in to your Google account in your Chrome in order to be applied throughout all your logged-in devices).

0

I was able changing going to on Settings -> Language. Very easy.

It affects also UI language.

enter image description here

0

From this answer from google to a question

To change the default region of any country domain to get it to function correctly:

  • Open the Google country domain you want to use for searching (e.g., https://www.google.de)
  • Open Settings > Search settings
  • Under Region Settings at the bottom of the page, select the region corresponding to the Google domain you're using
  • Scroll to the bottom of the page and click Save
  • You may also have to change and save the Language settings.
  • If you’re signed in to your Google account, the region will be saved in your account. If you’re signed out, the region setting will be recorded in browser cookies. If you’re using an incognito browser window the setting will be lost when the window is closed.

It worked for me. P.S. I'm always logged in.

Google's decision to ignore the languages you configure baffles me :|

Cheers

0

Browser extensions are good things. Let some nice developers maintain for you. (Don't make yourself direcly facing to bad UX design done by google)

Firefox: Google Search - Geolocation & Language Change

Chrome: Google Search - Geolocation & Language Change

Make sure you're applying 'language filter' rather than (only) 'GUI language'.

It is achieved basicly by doing query parameters stuff: hl=en&lr=lang_en ... Don't ask me for their full spelling. Ask google. Ugh!

0

I fixed it by clicking on the gear icon in Chrome's search results. Unfortunately, the popup menu was displayed in Italian, not English (like I have shown here). But it was pretty easy to see the menu option that needed changed:

enter image description here

-1

You need to change the language and the region in Google search.

On the google search page -> Settings -> Languages -> Change both "Which language should Google products use" and "Currently showing search results in" to English -> Save button

then... search page -> Settings -> Search settings -> Region Settings change to United States (or another English speaking country) -> Save button

1
  • Done this a million times even being signed in but the google never remembers the settings.
    – Jonny
    Nov 21, 2020 at 11:48
-5

adding language:en will give you English only results, not sure if that helps or is what you are looking for at all but it might at least kinda work.

2
  • 1
    Adding "language:en" where?
    – ale
    Aug 6, 2015 at 14:52
  • Just tried to add "language:en" in the query fields, without then with quotes, doesn't have the intended result. Aug 7, 2015 at 5:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.