I've two documents: in the first one I was able to add 'Script...' (as suggested here) from the Insert menu, but in the second one and all new which I'm creating I don't have this option present.

Why is this option is missing, and how I can activate this option or what do I need to do?

  • 1
    In both the old and the new Google Sheets, the script editor can be found under Tools>Script editor. If you're planning on adding a script, then that's the place to be.....
    – Jacob Jan
    Commented Sep 11, 2014 at 21:00

3 Answers 3


My guess is your 1st one is the old Google Sheets and your 2nd one is new Google Sheets, where the Script gallery has been moved to Add-ons and renamed Add-on store.

This is the answer to the question of which this has been deemed a duplicate:

The Scripts Gallery menu item will not appear in new spreadsheets if you have opted in to the new Google sheets (@Vidar S. Ramdal).


Now it has been moved to Extensions > Apps Scripts


If the Tools --> Script Editor and the Add-ons menu options are missing when you open the file, it probably isn't actually a Google Sheets file. Make sure to navigate to File --> Save As Google Sheets.

Then the Script Editor option in the Tools menu and the Add-ons menu will be available.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.