I'm trying to view a website that's on my Dropbox public folder. This website has some Google fonts that are being loaded externally, and apart from these fonts, most of the website is within the Dropbox folder.

When I copy the public link, I replace the https:// to http:// and initially this year, this link was working fine without any errors in the Chrome console.

Now, when I replace the same, it automatically adds back the HTTPS, giving no ability to view the site over non-secure.

I require nonsecure, because the console doesn't load a HTTP source (Google fonts) over a HTTPS connection (Dropbox hosted website). So Chrome doesn't let me view the proper fonts that are required for the website.

Please, could someone suggest a solution to this problem? I don't know when this setting changed in Dropbox, but this was working fine until summer this year.

1 Answer 1


I haven't been able to find a way to load Dropbox URLs over HTTP but it is possible to load Google Fonts over HTTPS, and that will prevent the browser from blocking the request.

For example:

<link href='https://fonts.googleapis.com/css?family=Roboto:400' rel='stylesheet' type='text/css'>
  • Well, the question is old.. I had already figured that out. Thanks for the answer anyways... :)
    – mk117
    May 26, 2015 at 7:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.