4

I'm not able to enable offline drive in either the new or old Drive interface.

In the new interface, I select "Offline" > "Sync..." > "Done", and when I open the dialogue again, my settings have have not changed.

enter image description here

In the old interface, I select "Enable Offline" and the page never completes loading, and I get stuck in an endless loop of network requests to:

https://docs.google.com/static/doclist/client/js/2418050222-offline_launcher_i18n_offline_launcher_core.js

304 response

https://docs.google.com/offline/optin?json=1

400 error

enter image description here

Screencast gif here: https://dl.dropboxusercontent.com/u/126030141/Share/offline-drive.gif

2
  • 1
    Anything that might be getting in the way? Adblocker browser extension? Proxy?
    – ale
    Oct 24, 2014 at 1:17
  • Just tried again with 0 extensions enabled, all my other chrome and network configurations are standard, and still can't enable, Thanks for the suggestion though, I hadn't thought of that. Oct 25, 2014 at 20:07

1 Answer 1

1

This is due to the user being logged in with multiple accounts (which can be checked by clicking on the user profile picture icon on the top right corner of Google Drive). By being signed in with multiple accounts, Google Drive would be clueless about which account to use when accessing https://docs.google.com/offline/optin?json=1.

One simple workaround is to sign out of all accounts and log in with the specific account that you wish to use for Google Drive offline. Please note that this only works for Google Chrome and only one account can have Google Drive offline at any one point (unless using multiple users in Google Chrome).

Note: This is similar to Gmail's Error 400 Bad Request, which has been explained in more detail here.

1
  • Great answer, thank you! Google may have pushed a recent fix however, because I was able to successfully sync offline today while logged in to multiple users. Nov 17, 2014 at 19:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.