4

I'm trying to get IFTTT to send me an email from this minimal test feed I created:

http://iftttrss.99b273199898d3dbd62e8db4ad65cf7f.madis.db.bcinfo3.barrycarter.info/

IFTTT accepts the feed when I add it, but the logs repeatedly say things like:

Feed Trigger Error about 6 hours ago
An error with Feed prevented your Recipe from working.
After five consecutive errors your Recipe will reset.
If errors persist, visit the Help page for support.

The Help page is, of course, unhelpful.

Here's what the feed looks like:

<?xml version="1.0" encoding="ISO-8859-1" ?><rss version="2.0">
<channel><title>iftttrss.99b273199898d3dbd62e8db4ad65cf7f.madis.db.bcinfo3.barrycarter.info</title><description>DB_QUERY</description>

<item><title>Untitled</title><link>http://barrycarter.info</link>
<description>title: 2014-11-03 16:49:05, date: 2014-11-03, time: 16:49:05, </description>
<guid>9ff63fad584a8cfad58370f874c9a8d7d9642ead</guid>
</item>
</channel></rss>

Thoughts?

Note that simply editing the feed until it works isn't a great option, since IFTTT appears to check feeds only once every 3 hours(?).

Since the feed isn't rejected when I add it (like some of my older attempts were), I'd have to wait 3 hours between each test or something like that.

UPDATE: I deleted and readded the RSS action, and ifttt.com tells me this:

created 4 days ago
never triggered

My access logs, however show:

198.58.102.158 iftttrss.99b273199898d3dbd62e8db4ad65cf7f.madis.db.bcinfo3.barrycarter.info - [09/Nov/2014:18:50:04 +0300] "GET / HTTP/1.1" 200 696 "-" "Superfeedr bot/2.0 http://superfeedr.com - Make your feeds realtime: get in touch"

So I'm confused. This feed just prints the current time and date and is thus constantly changing.

  • Have you run it through an RSS validator? – ale Nov 3 '14 at 21:26
  • @AlE. D'oh! Found several errors, working to fix them now, thanks! Was hoping IFTTT would've caught them at 'add' time, but apparently not. – barrycarter Nov 3 '14 at 21:44
  • @barrycarter Could you please add that as a self-answer then? I'm not sure whether this particular solution would be applicable in any other situation, but if you can generalize what the issue was, that would be great. – jonsca Nov 4 '14 at 7:36
  • @jonsca Waiting to see if IFTTT accepts the revised, validated feed. So far, the logs show it hasn't tried to access the feed since I fixed it. – barrycarter Nov 4 '14 at 13:53
  • 1
    @arieljannai My fault. I've now accepted an answer. I hate it when I see unanswered questions that have really been answered, so I try not to be guilty of it myself. – barrycarter Jul 3 '18 at 21:40
5

Julien from Superfeedr here. We are polling and parsing feeds on behalf of IFTTT. I just things on our end and, at this point, we are able to fetch and parse the feed... However, it's ugly:

<?xml version="1.0" encoding="ISO-8859-1" ?>
<rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom">
<channel>
<atom:link href="http://iftttrss.99b273199898d3dbd62e8db4ad65cf7f.madis.db.bcinfo3.barrycarter.info" rel="self" type="application/rss+xml" />
<title>iftttrss.99b273199898d3dbd62e8db4ad65cf7f.madis.db.bcinfo3.barrycarter.info</title>
<link>https://github.com/barrycarter/bcapps/blob/master/bc-run-sqlite3-query2.pl</link>
<description>DB_QUERY</description>

<item>
<title>Untitled</title>
<link>http://barrycarter.info</link>
<description>title: 2014-11-10 09:34:26, date: 2014-11-10, time: 09:34:26, </description>
<guid>http://Untitled</guid>
</item>

</channel>
</rss>

Make sure you add real content in it and make sure it propagates (wait at least 15mins because you do not support PubSubHubbub apparently for now).

Add an entry like this

<item>
<title>My First entry</title>
<link>http://barrycarter.info/link-to-by-first-entry</link>
<description>The content of my first entry</description>
<pubDate>Sun, 09 Nov 2014 03:41:14 GMT</pubDate>
<guid>guid-for-my-first-en</guid>
</item>

Make sure you adda pubDate to your items too... this will only make things easier :)

  • Wow, an actual official answer-- this InterWebs thing is terrific ;) ... but seriously: this is just a test feed to make sure I can get things working: real data will come later. According to ifttt, "created 5 days ago never triggered". Is there a reason ifttt isn't seeing this feed as updated? What should I do to make this feed look like its continuously updated? – barrycarter Nov 10 '14 at 11:24
  • Please, check the addition above :) – Julien Genestoux Nov 10 '14 at 14:25
  • Thanks, Julien! I added a pubDate and I just got a "Feed Trigger Error" in my logs. Time to contact support, methinks – barrycarter Nov 11 '14 at 19:04
  • Could you please provide a complete, minimal viable example? – William Entriken Dec 27 '16 at 14:52
0

I had the same issue and I think I may have figured it out. Link should be in a different format:

http://www.domain.com/forum/rssfeed=1

And not

http://forum.domain.com/rssfeed=1

Also, validate it here: http://validator.w3.org/feed/

  • I should've updated this earlier, but it turns out ifttt/superfeedr dislike feeds with only one item. – barrycarter Mar 4 '15 at 22:12
-2

I had the same issues and was able to correct by adding https to the feed instead of http.

For this particular example:

https://iftttrss.99b273199898d3dbd62e8db4ad65cf7f.madis.db.bcinfo3.barrycarter.info/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.