2

When I paste one sentence in the left field of Google Translate it gets translated. However, if I paste a whole paragraph nothing gets translated and the right field doesn't change at all. Is there a way to make it translate more than one sentence at once? Does it depend on the language? I am translating Bulgarian to English.

2

Hit the [Translate] button above the "right window". ;)

Translate button on Google Translate - above right text box

When you paste (or edit) a larger block of text Google does not seem to translate it instantly (on-the-fly), but instead waits until you have entered all the text you want translated. So you need to manually hit the [Translate] button. Probably because translation is computationally expensive. Although it is a bit misleading that a link at the bottom of the page still states "Turn off instant translation" in this case, implying that "instant translation" is active. Toggling this option does not seem to make a difference with large blocks of text.

| improve this answer | |
  • 1
    Now I am embarrassed for asking this :) But tech does seem to spoil us with time... – Alexander Nov 6 '14 at 9:55
  • 1
    Ha, well, like you say we do get used to things "just happening", like not having to hit the [Save] button etc. It's also a bit misleading that there is still a link at the bottom of the page to "Turn off instant translation", implying that it is still active. – MrWhite Nov 6 '14 at 10:22
  • 1
    I did just check to see if there was a keyboard shortcut, but couldn't find one... support.google.com/translate/toolkit/answer/147834?hl=en – MrWhite Nov 6 '14 at 10:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.