28

When I enter the person's name in the To field, the auto-complete comes up, and lists the several email addresses that I have for this person. The first email address that it lists, is not the one that I want to email.

In the contact entry for this user, I have the email address I want to use as the top one. I believe this used to work in gmail, but doesn't anymore.

Is there a way to set the default email address for a person?

10

The email address in the first position of the contact's settings is used to decide which of your contact's pictures to display. He/she must have set it for public display in gmail's settings for this to work.

The email address that is shown on top for auto-complete is the most contacted address, as far as I know.

  • This seems to be the case for me. I went through some of my other contacts that have mutliple emails, and this is the case every time. – mlsteeves Oct 1 '10 at 7:35
  • This does not seem to be the case always. I have several examples of a contact with more than one email address, and not having the first address pop-up as the first option for that person when sending an email. – Daniel Aug 15 '13 at 17:15
  • @daniel - The answer above was for default setup. It gets changed over time as GMail tracks your interaction to set the order. Asssuming that its a fresh account without any email interaction and you create a contact with two email addresses OR create a fresh contact with two email addresses and you will see the order difference while composing the email. – Jwalant Natvarlal Soneji Aug 22 '13 at 20:27
  • I do not understand this answer. When you say that the contact must have set it for public display, does that mean that I cannot change the default email for the contact, but it is in someone else's control? What if the two email addresses in a contact record belong to two separate Google accounts, which one will be default? – Flimm Jan 2 at 15:34
  • Hi Flimm, below scenario should help. Assume, you had my email address in a contact in your Gmail. It won't show the picture of mine unless I have associated one to my email inside Gmail settings, or you have had set a photo in the contact in your contact list. When it comes to seeing the photo I had set, I need to mark it for available for Public display so that it shows me. Also, if one contact entry in your address book has two email addresses, it will show the photo associated to the first email written in that contact entry. – Jwalant Natvarlal Soneji Jan 4 at 4:50
1

I had a contact with two email addresses:

  • x@gmail.com
  • y@company.com

And in my prediction list, it would choose y@company.com. I was able to change the default by removing the second email address and re-adding it.

  • I tried this, but it didn't work for me. – Sam King Jan 9 '14 at 3:09
-1

I GOT IT!! Copy the secondary email - hold it somewhere. Delete the PRIMARY or default one. SAVE it. You have to save it. Then edit again, and paste the secondary one in as a new email. It keeps the older one as primary. Save and quit.

New contributor
Carl Scheider is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Can you explain where the user has to do this? I don't see that/how it answers his/her question... – Jan Doggen 2 days ago

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.