8

A "Tasks" calendar appears in my list of "My Calendars" in Google Calendar. It's only a minor irritation, but I have a small screen, I don't want it and never plan to use the Task list. Can I stop it appearing or remove it? When I look at the Settings page for my Google Calendar account, it appears that it cannot be deleted.

5

I recently set up the following Stylish script as a very hackish workaround for this:

@namespace url(http://www.w3.org/1999/xhtml);

@-moz-document url-prefix("https://www.google.com/calendar") {

  .calListChip[title='Tasks'] {
    display: none;
  }

  #calcontent.eui-t .calListRow {
    height: unset;
    line-height: unset;
    max-height: 19px;
  }

  .calListRow {
    height: unset;
  }

}

The CSS selects the div containing the content for the Tasks entry and sets it to not display. It also sets the divs which allocate space for calendar entries to use max-height rather than height to determine their size, which in turn allows these divs to collapse if they contain no rendered content (such as in the case of the Tasks calendar entry).

This CSS will not get rid of the 1 pixel white border at the bottom of the Tasks entry. If the background of your calendar listing is white, this will be unnoticeable, but if the background of that section is a color other than white, you will have a double thickness border where the Tasks entry used to be.

If you wish to remove the Birthdays calendar as well, add the following code block to the indented section of the Stylish script:

  .calListChip[title='Birthdays'] {
    display: none;
  }
  • 1
    Hey, your selector has the issue of hiding more than just the tasks one. Why not use this selector: .calListChip[title='Tasks']. This selector is associated with any calendar item that has the title "Tasks". Should hide only the Tasks one. Works for me! – ComputerLocus May 11 '15 at 13:55
  • 1
    @Fogest While that selector does indeed affect only the Tasks calendar, it selects the div inside the one that allocates space on the page for the calendar entry. The downside to that method is that it leaves a visually blank space between calendar entries where the "Tasks" entry used to be. It's not a bad solution, but it has its own negative side effects. In the most ideal case, you would select the parent of that selector (doing so would do exactly what we want), but at this time, CSS does not yet support that. – redyoshi49q May 12 '15 at 11:55
  • @Fogest After looking at my DOM editor once more in light of your comment, I updated my answer with a Stylish script that uses your suggestion and incorporates additional CSS tweaks that appear to fix the "gap in the entries" issue that your suggestion originally had (though I've only tested it on my own browser). See if the current answer works better on your end. Thanks for the suggestion, by the way. – redyoshi49q May 12 '15 at 13:12
6

Unfortunately, like the "Birthdays" calendar, you can't unsubscribe or otherwise remove the "Tasks" calendar. The best you can hope to achieve is to not have any entries appear in your calendar (by de-selecting it).

The Tasks widget on the right is at least hide-able/removable. (Click the close button on the widget or minimize the whole panel.)

  • At least the birthdays calendar can be made invisible in the settings. The fact that Tasks is missing there led me here ... :( What's likewise annoying: You can change the title of the birthdays calendar - which is handy as this allows to group related calendars like e.g. this: "Family: Deaths", "Family: Birthdays", "Family: Jubilees" - but not so for "Tasks", which is there like some massive blackhole. – phresnel Jan 22 at 9:51
2

Figured this one out - hit the Cog when viewing your calendar and switch your view (temporarily) from "Compact" to "Cozy". An arrow will appear on the divider between your calendar and task list. Click that! Then you can switch back to "Compact".

0

You cannot remove Tasks, it has the same active-status as your primary calendar. You can see this under Settings(Cog Wheel)->Calendar(Tab)->'SHOW IN LIST', it is greyed out for Tasks just like for your Primary Calendar :(.

Why? Heck if I know. Maybe Google is just so large that it got lost in confusion :(. Whatever the reason, just add a Calendar Task for 'Enable Show in List for the Task calendar' to your Google Calendar ;)...

enter image description here

0

you can switch to reminders by selecting the dropdown menu next to the "Tasks" calendar as shown here: enter image description here

0

Not really a fix, but if you hit the dropdown arrow on the left of MY CALENDARS they all disappear. At least you don't have to see it. This works the same for OTHER CALENDARS btw.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.