3

I just moved from Sweden to France. Since I got here, everytime I loaded Google's search page I am asked if I want to change from google.se to google.fr. Seeing that I currently do more searches related to Sweden than to France I want to remain at .se. Unfortunately, by mistake, I clicked "Change to .fr" and now I can't get back. I can get to .com but not to .se. On the search settings page I have changed the language but it does not affect the domain.

I know about /ncr but I am pretty sure there is another method (I move to France every winter and I have not had this problem before).

  • Try deleting your browser’s cookies. (The one(s) related to Google.) – Alex Jan 13 '15 at 15:40
1

Try with browser in private navigation mode. If that works, consider to delete the cookies related to google.com and Google local pages [1].

Also you could try setting a location. From [2]:

  1. Do a search on Google.
  2. Scroll down to the bottom of the search results page where you can find the current location that Google has for you. The location may be coming from your IP address, your Location History, your Wi-Fi connection, or any locations you've set at www.google.com/preferences.
  3. To update your location, click Use precise location or Update location.

Referencees
[1] Google.com goes to the wrong Google page
[2] Change your location on Google

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.