5

For more than 3 months Ctrl+V doesn't work when I want to paste something into Facebook comments. I can only drag and drop into the comment box. But my friends say they don't have problems with it...

Upon Ctrl+V the UI screws up and the caret doesn't insert characters where it blinks, also home and end and other navigation buttons begin to scroll the page instead the caret in that edit box. Only way to get out of there is refreshing the whole page. Looks like the whole edit control is controlled and implemented in JS.

If I create a new firefox profile, it works. So I'm suspicious that some addon causes the problem. But I don't want to lose my entire profile by starting a new one just for the sake of Facebook's stupid tricks.

So what I tried so far:

  • Delete all cookies and the entire browser history: no avail.
  • Erased the browser cache: no avail.
  • Disabled all addons (although I uninstalled none): no avail.

What else can be screwed up? Maybe disabled addons still have an effect on the browser?

I'd like understand what happens and fix the problem based on that instead of the usual "try format your hdd and reinstall you OS" tips, other forums often give.

  • 1
    I am voting to close this question because it is about Web browser functionality. – ale Mar 24 '15 at 15:12
  • 1
    @AlE. I don't think so, this problem happens only when using Facebook, because they are using a non-standard control to write comments, and probably some javascript hacks that break the browser... Nowadays even the Ctrl+shift+U combination that's used to write unicode characters on Linux makes the Firefox crash... But only on Facebook, and nowhere else. – Calmarius Mar 24 '15 at 15:40
3

I had the same problem and the following worked for me:

Went to about:config and changed the value of dom.event.clipboardevents.enabled to true.

I got this from: http://forums.mozillazine.org/viewtopic.php?f=38&t=2925719

  • Setting this to true made me unable to paste at all. Setting it to false allowed me to paste, but everything to the left of the insertion was silently removed (it was visible, but submitting made it disappear). – mafu Nov 20 '15 at 23:37
  • It worked for me like charm. I was bugged up with this for many days. Many thanks! – Atul Jan 14 '16 at 2:44
  • 1
    This fixed it for me, but i set it to false for a reason! To stop websites inserting junk in the clipboard when I copy from articles. We really need an addon that sets this flag on a whitelisted basis. – imoatama Jan 21 '16 at 0:38
  • It was true. Neither changing it to "false" nor returning it to "true" did anything for me. – user59777 Jun 13 '16 at 7:56
0

Restarting Firefox in Safe Mode didn't fixed the problem. So the least destructive way was choosing "Refresh Firefox" and reinstalling add-ons I need. Now Ctrl+V seems to work in Facebook. I don't know what caused the problem. Probably someone else could give a more detailed answer which I will accept.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.