14

Is it possible to set the default tab to four spaces in Google Docs? I'm gonna take an interview with Google and supposed to code in Docs, but the tab is much more than the usual 4 spaces, which makes coding a pain. Does someone know how to set tab to generate 4 spaces every time it is pressed?

A related question was asked but the answer does not work in my case since I want tab to generate 4 spaces every time it's pressed.

4
  • can you install lifehacker texter?
    – malarres
    Mar 5, 2015 at 14:54
  • Unfortunately, I am using Mac OS X, not Windows, which is incompatible with lifehacker texter. Any way to get around this issue? Mar 5, 2015 at 20:08
  • 1
    if you can avoid using º character, then you can go to Tools > Preferences and replace º with three spaces, then when you press space this is substituted for a total of four spaces. Not the ideal solution, but it can work
    – malarres
    Mar 6, 2015 at 9:58
  • (I tried to replace tab with a series of spaces but this is not supported)
    – malarres
    Mar 6, 2015 at 9:59

4 Answers 4

2

It's somewhat cumbersome but you can set as many tab stops as you want, and docs will move nested tabs to the next tab stop as well. For example:

tab stops

You can add tab stops by right clicking on that tab bar where you want the tab stop to be and clicking Add left tab stop.

2
  • how do I remove the tab stop?
    – Alex
    Jun 25, 2021 at 4:57
  • The only way I know of to remove stops is to merge two by dragging them together.
    – Zane
    Jun 29, 2021 at 15:09
1

Click the upper ruler on the top of the document, click "add left tab stop", then adjust it to 4 spaces from the "left indent".

Its in this link in the section "Tab stops": https://support.google.com/docs/answer/183618?hl=en

Source: https://stackoverflow.com/questions/19122111/how-set-tab-indent-to-four-spaces-in-google-docs

1
  • Where is this "add left tab stop"? Or how does it look? Did you see it working? Jun 3, 2020 at 5:28
0

I had this same issue - you can set a left tab stop for a single line, but not all of them.

I resolved this by globally selecting the document and then setting a new tab stop.

Not the best solution, but it worked.

0

The workaround I use, since I produce only "code" based documents, is I use the "find and replace" feature (cmd+shift+h on mac). With \t replaced to four spaces, and the "use regex" checkbox on.

The nice thing is that the "find and replace" dialog memorizes the settings for the document, and so if you do the shortcut and apply, it takes about 1 or 2 extra seconds, so quite fast (but still a pain in the ass as opposed to a native google docs solution).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.