2

I'm getting my mail in Gmail from base account and four additional accounts, fetched via POP3. For each account Gmail offered (when adding) auto-labelling mechanism, which I used. This seems to be working perfectly only for incoming mail and fails for outgoing mail.

In particular:

  • all e-mails received via base or any of these external accounts are correctly labeled,
  • mails sent via any of external e-mails are only labelled, when I reply to someone's mail,
  • if I start new message and send it, it is not labelled at all,
  • mail sent through base @gmail.com address is not labeled correctly in any circumstances.

Here is an example -- only replies are correctly labelled, initial e-mails are not:

enter image description here

To "fix" these problems, I have created several Gmail's filters. One even in two copies:

enter image description here

In brings no help.

Is this some kind of bug or by-design and results, that I'm getting are correct? Or am I missing something or doing something wrong? Even if auto-labelling mechanism is intend to work for incoming mail only, then why my filters does not work?

  • Do you want to know if it is only possible for incoming emails (which you already figured out yourself) or do you want to have a solution for outgoing emails? – Jacob Jan Tuinstra Mar 10 '15 at 20:15
  • I think, you can figure out (from the fact, that I wrote about my unsuccessful attempts to "fix" this), that I'm willing to find a solution, that will work for outgoing e-mails! :> Unfortunately, Al E.'s answer explains, that this is not possible. – trejder Mar 11 '15 at 13:16
2

Gmail filters only fire on incoming messages, so this would seem to be working as designed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.