7

On the Google Calendar page I can access via a web browser, I can click on:

Settings cogwheel | Calendars | to the right of any calendar entry click Edit notifications.

The help icon next to All-day event notifications: says:

Event notifications tell you about an all-day event at a specified time some number of days before it begins. For example, if you’d like to be alerted about an all-day event at 9 am the day before it occurs, you’d set a notification.

However, IMHO there are several use cases where one would need to be notified during the same day about an all-day event. The classical scenario is birthdays. I don't want to know about them the day before, but during the same day, perhaps in the morning around 8:30, or perhaps in the afternoon after work hours around 7:00 PM, these are the times when I would like the notification to be sent out for such all-day events, not the day before.

  • Is there a way to configure such behavior in Google calendar, and if not then why is it missing / why is it not possible to program such behavior into Google calendar?
2

OK, perhaps the help message had some issues, but now I see that when I go to a specific calendar's Settings | Edit notifications tab I have the opportunity to set the following under "All-day event notifications:" which would pertain to the selected calendar whose settings I would be configuring:

  • Notification method: pop-up, e-mail, or SMS
  • specify 0 days before event to have the event reminder on the very same day
  • specify the time (e.g. 6:30) you want to be notified about the event

You can even set more than one notification of the same type for either all-day events or regular events, and can set as many plans to receive notifications as you want.

  • Seems like it doesn't work anymore :( When I set "0 days before" calendar doesn't notify via popup or any chrome notification at all. Same situation with Android Google Calendar App. Popup works only when I set ">0 (1,2...) day(s) before", but email works even with "0 days before". – b0rman Jun 5 '16 at 20:45
0

No. It doesn't work. I tried and thought it will trigger a notification at 12 am but it didn't.

Best solution is to set as 'event' at 12am the same day.
As Google calendar doesn't snooze (baffles me still why such a simple tool can't be configured, it's 2016 for crying out loud ), I have downloaded Calendar Snooze at my android to work with GCal.

  • Please do not include additional questions in the answer space. – jonsca Jul 16 '16 at 19:43
0

This was not working for me when I tried to get notifications on my phone for a Facebook birthdays via an ical feed.

After a lot of troubleshooting, this finally seemed to work:

  1. Create ical Calendar using HTTPS link instead of webcal link. Example: https://www.facebook.com/ical/b.php?uid=XXXXXXXXX&key=YYYYYYYYYY

  2. Import your Calendar via URL

  3. Enable your Calendar here: https://calendar.google.com/calendar/syncselect

  4. Go to your phone, head over to Calendar app. Turn syncing off for that Calendar, remove any All-day event notification settings.

  5. Now add the desired All-day notification setting and turn syncing back on. You should now receive notifications properly going forward.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.