3

I'm trying to share a file for download via Google Drive. It appears that Drive is detecting the filetype (it is a zipped archive) and making it quite difficult to do so.

I have uploaded the file and my sharing options are set like so:

link sharing settings

When I access the link via my account it shows up like so. Note that I have a download icon that I can use to download it:

viewing file with owner's account

And yet when I access the link via incognito mode it shows up like so. Note the lack of a download icon:

viewing link in incognito mode

I've tried rewriting the URL as recommended by some websites but just get a permission issue:

"Sorry the owner hasn't given permission to download this file"

This makes me think I'm doing it wrong. Where is the ability to set this file as download-able? It seems like the height of insanity to have removed this ability simply because they have 'detected' the filetype of this site. But then Google have done crazier and more backwards things in the name of usability I suppose (good old Gmail being unable to download filetypes it doesn't recognise comes to mind).

migrated from superuser.com Mar 24 '15 at 3:43

This question came from our site for computer enthusiasts and power users.

  • Have you tried accessing the file from the link using 'regular' (not incognito) Chrome after logging out of your Google Account? – Brian Mar 22 '15 at 12:48
  • No - but I have asked friends to try accessing the file from the link from their accounts - they are unable to. – fostandy Mar 22 '15 at 22:50
3

Have you tried setting up a file for download with a different file extension, something innocuous like .txt? Google may be trying to prevent people from hosting viruses/malware by disallowing anonymous downloads of .zip, .exe, etc. files.

  • Thanks - renaming to .txt or .bin seems to allow it to be downloaded. This is good to know but frankly not worth the effort. I'll just use dropbox as they clearly have a better idea of what constitutes a good user experience – fostandy Mar 28 '15 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.