3

Whenever I try to write an English word in an Arabic paragraph in WordPress it becomes like this:

بواسطة متجر Microsoft الإكتروني الرقمي

where it should be like this:

 الإلكتروني الرقمي Microsoft بواسطة متجر

The problem is in both the text editor and the theme (doing page Preview/live).

The theme I have supports RTL. I installed both TinyMCE and WP RTL without success. I was told it may be fixed with CSS editor for the theme but I'm totally clueless when it comes to programming (if I may call it that).

1

The way I fix it only in the live page is by adding a special tag to each Arabic post (for example tag arabic) then in theme CSS I add:

tag-arabic {
direction: rtl;
}

You can add that CSS line through your theme (most new theme settings have a page where you can add custom CSS).

For the WYSIWYG text editor, you can use this plugin: https://wordpress.org/plugins/contents-direction/

  • Welcome to WebApps. I formatted the code snippet: see formatting help. Since the answer field is reserved for answers only, I edited the part of your post that looked more like a question. – user79865 Mar 23 '16 at 19:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.