5

I'm trying to send an email to an address that I've sent to several times before, but Gmail does not autocomplete it. Is this expected behaviour? Must I add that address as a contact before Gmail can search it?

2

Must I add that address as a contact before Gmail can search it?

It would seem so.

You've probably turned off this setting, in order to keep Gmail from adding just anybody to your contacts.

"Create contacts for auto-complete" setting

According to Gmail Support

When you type an address in the To, Cc, or Bcc field of a message you're composing, Gmail will suggest addresses from your Contacts list. Hit Enter to choose the name at the top of the list, or scroll down to choose a different address. If Gmail doesn't suggest the address you want, just continue typing.

Gmail will first suggest the addresses you send mail to most often. To view a complete list of your most frequently mailed contacts, click Gmail at the top-left corner of your Gmail page, then choose Contacts. Next, click Most Contacted.

So, in order for the auto-complete to work, the person/email address needs to be in your contacts. Your browser may have offered auto-complete before (if you set it to do that with web forms) but Gmail's fields are far from being simple HTML input fields.

If the person is in your contacts and still not coming up in auto-complete, then Google suggests that it's probably your browser. Use a different one or, if you're sure it's supported, clear your browser cache.

  • 1
    Hmm. I find that it will autocomplete email addresses, but not names. – Sherwood Botsford Jul 22 '17 at 11:50
  • Still seems to be the case 3.5 years later. Sad. – Matt Nov 12 '18 at 14:19
0

I found what I think is an odd scenario that kept a contact from auto-completing. I was going crazy for a while. Here's what can happen: Let's say you first email someone by just typing in their email (not a contact, just their email address.) Not sure if it matters how many times you send to them or not, but for a while, I was just using auto-complete for their email to contact them. Then later, I knew their phone number and figured I'd set up a real contact for the person. I believe I manually created the contact and typed or pasted in that email address. After that, auto-complete would NOT work by trying to type the person's name. This thread got me thinking about "other contacts," so I went there and found the email address and deleted it from there. After doing that, auto-complete worked for using the person's name. This certainly seems like a bug to me, but it resolved the issue.

  • This is similar to what happened to me.. I had a contact get auto-added to contacts with a nickname... so even though I kept sending to him, it never put his full name in contacts, because there was already an entry with a different name. I search for his email address in contacts, and fixed his name and now it completes. – David Jeske May 2 at 23:10
-1

Some times it would have that problem,you can turned off this setting that you can keep Gmail from adding just anybody to your contacts.

-1

I've had the same problem for a year. Gmail wouldn't offer me suggestions of contacts.

Went to Android Settings, Apps, Gmail. In the App Permissions section, I found Contacts disabled. Enabled it, closed everything.

And after I opened gmail, it was giving me suggestions of emails as I was typing.

So, enabling the contacts permission for Gmail in my case solved it.

  • This is Web Applications. Questions, and Answers, are expected to be about web app problems and solutions. How will an Android setting have any bearing on the address auto-suggest in the web version of Gmail? – ale Jun 19 '18 at 12:48
-2

On Android, this may be happening because the Contacts app was recently updated or installed. You may need to launch the Contacts app, then it will ask for permission to access your contacts. Once you approve that, then Gmail should be able to autocomplete the email addresses and contacts.

  • 1
    This is Web Applications, so it's assumed that the question is about using the web interface and that answers would follow suit. – ale Jan 24 '18 at 3:38

protected by Community Dec 26 '18 at 23:34

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.