I'm having a strange issue in Gmail.

I couldn't edit the text that was already typed. It overlaps the existing text. The cursor itself looks boxy instead of line.

It's hard to explain with text, So here is a GIF what I mean.

animated GIF of issue

Any idea how to get rid of this annoying thing?

Some details

  • Chrome Latest
  • Windows 8.1 64 bit

I tried refreshing my Pinned Tab, But it still exist. When I opened in a new tab, it works fine but again after some days, again the same issue.

  • 1
    What you are experiencing is consistent with being in "overtype/overwrite" mode (ie. toggle the "Insert" key on your keyboard.) I can toggle this by simply hitting the "Ins" key when composing a message (although there is no indication when it is active and when it is not). However, how did yours get activated to begin with? And can you turn it off? A lot of people seem to have had this same problem with Gmail and there appears to be just as many solutions?! Try Googling gmail overwrite mode. Nice example/animation btw!
    – MrWhite
    May 1, 2015 at 14:48
  • Oh.. yes.. Thank you... Feeling like a newbie :) I'm not sure how I pressed "insert" button, Now its fixed... You may write it as answer :) I googled this for an hour, but didn't get any solution because of the wrong phrase. The word "overtype" is new to me.. Thanks Anyway .. May 2, 2015 at 12:12

5 Answers 5


As mentioned in comments, what you are experiencing is consistent with being in "overtype/overwrite" mode, as opposed to "insert" mode (the usual default). This mode is usually toggled by simply hitting the Insert or Ins on your keyboard. (Which might require a key combination on some keyboards - particularly laptops.)

I get the same result if I hit the Ins key whilst composing a Gmail message, although there is no indication as to the selected mode in Gmail (or the browser) itself.

Bizarrely a lot of other people seem to have experienced the same problem in Gmail without having knowingly triggered overtype mode on their keyboard. Although the threads I've seen on the subject don't appear to be entirely conclusive, it maybe that on some keyboards, overtype mode might be triggered inadvertently with some alternative key combinations.


In case it helps anyone - I think one reason people might think that the insert key does not work in Gmail is that it only seems to toggle between modes when in the message body of a compose window. In the subject line insert seems not to have any effect. I encountered this and if it is happening in the Subject line you need to move to the main compose window to toggle. It is also worth noting that it does not change across accounts if you have several different email addresses open. It is only for the one gmail account that you accidentally activated it on.

  • The same is true in Inbox, including when you are trying to add a reminder - you need to open a box to compose a new email and press the Insert key while in the body of an email. Not sure how I arrived in Insert mode in the first place.... Aug 11, 2017 at 13:07

I've had this happen to me while using Gmail via Chrome with no idea on how. I finally figured out how on my particular laptop. I seem to have accidentally punched the "fn" key and the "PrtSc" key at the same time. My particular "PrtSc" key also has "ins" in tiny letters in the top left of the key. Clicking them again at the same time turns the overtype mode back off. I also have "ins" at the bottom of the "0" on my attached number keypad, but that doesn't seem to trigger the overtype mode for me.

  • in my similar case, it must have been pressing Fn-H (the H key has "Insert" written at the bottom) on my 65-key keyboard. That was the solution, anyway, pressing that combination.
    – Kai Carver
    Jan 19, 2021 at 19:27

I ran into the same issue. I was able to find my insert key, and it did not appear it was functioning.

It appears that google chrome and more specifically gmail only 'enable the toggle' of overtype mode in certain text boxes, however, this overtype mode once enabled is applied to other text boxes. So....

If your Insert key works (i.e. works in word or excel given enabling the key) but you are struggling in gmail. This could be the issue:

COMPOSE a new message

go down to the BODY of the new email (not the subject) and my insert key is functional there, toggling Overtype on and off. If I toggle overtype ON and then trash that message, overtype is still enabled for various parts of gmail. However in the search bar, or even the subject line of a message, the insert key is not enabled, meaning it can't be toggled off.

reply to a message, or COMPOSE a new message, go to the body of the email, and the insert key once again can toggle Overtype on or off.

Hope this helps someone.

  • 1
    Just realized this was answered above by Chris. Could have saved myself an hour by just reading more. Sorry for the duplicate post.
    – Scott
    Jul 15, 2016 at 18:19
  • You can delete it anytime.
    – serenesat
    Oct 13, 2016 at 13:29

I was having the same problem but with google tasks when attempting to add a note to the task. I was able to go out of the note and click on a main task body then hit the insert button on the keyboard. When I went back into the notes it allowed me to edit again.

Not the answer you're looking for? Browse other questions tagged or ask your own question.