1

I have a Google Voice number, and can send and receive SMS messages using both the website (through gmail.com) or from the Hangouts app on my Galaxy S3.

If I have an open desktop web browser on Gmail, and receive an SMS message, my browser pops up the message and gives me a notification, but nothing happens on my phone (I can open Hangouts and see the message - I just don't get any notification). This happens even if my web browser doesn't even have the Gmail tab active, just if it's open in the background.

If my web browser is closed, then the notification happens on my phone.

I'm assuming Hangouts thinks that since the message came through on my browser, that I don't need to be notified on the phone.

I don't see any setting on Gmail, Google Voice website, or in the Android app for disabling this - anyone have any ideas on how I can get notifications on my phone even if I have a browser open?

  • What if you don't have the chat box open, but have it minimized in Gmail, is it still an issue then? – ComputerLocus May 11 '15 at 13:46
  • It's weird - the more I test it, the more inconsistent it gets. Seems like the messages go to the phone even if GMail is open, but if I acknowledge and close/minimize the chat from there, future messages in that conversation don't go through to the phone. If I F5 the browser, seems like only the very first message goes to the phone notification - which is good enough but still weird. And then I tried closing the GMail browser tab completely and it still only notified my phone about half the time. – Joe Enos May 11 '15 at 16:10
  • I am getting a new phone in a week, so I wonder if that will make any kind of difference - this is an S3, getting an S6 next week. – Joe Enos May 11 '15 at 16:11
  • I am not sure what the problem is. Sounds really weird. Have you tried a different browser? Google Chrome? – ComputerLocus May 11 '15 at 16:12
  • The only browser I've used on the desktop is Chrome. – Joe Enos May 11 '15 at 16:13
1

Short answer

The described behaviour is by design. There isn't a setting to disable it.

In Google words...

From [1]

Hangouts are synced automatically across devices, so you can start a Hangout on your computer and continue on another device, like your phone.

References

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.