The recommendations I've received on LinkedIn appear just fine. I've given a recommendation to a person I believe I friended in an “other” capacity. It shows up on their profile, but it is not displaying on mine.

How do I make sure the recommendation I wrote for someone else displays on my own profile?


I don't see a "Given" link in the top right of the Recommendation section on my profile. All I see are "Ask to be Recommended" and "Manage". When I click on "Manage", it brings me to the Recommendations page, which includes links for "Received" and "Given". Under "Given", the given recommendation appears, with the option selected to "Display on my profile" to "connections." However, nothing is displayed. Is it possibly because I have not worked with this person, and friended them in an "other" capacity?


Recommendations that you write for other people appear:

  • In the Recommendations section on your profile. You'll need to click the Given link in the top right of the Recommendation section to see them.
  • In the Recommendations section on the recipient's profile, after they accept the recommendation.

To hide or display a recommendation that you gave:

  • Go to your profile.
  • Scroll to the Recommendations section and click the Given link.
  • Scroll to the recommendation you want to hide or display.
  • Under Display on your profile to, select Your Connections, Everyone, or No One.

Note: This only changes how the recommendation displays on your own profile. It won't hide it from the recipient's profile. You must remove your recommendation to prevent it from displaying on their profile.

For more information look at LinkedIn help center of Hiding and Unhiding Your Recommendations.


When you click on Profile tab you simply enter in edit profile mode. So that time it does not show Given link. But if you click on View profile as (a tab near to you profile picture), It show how your profile looks to your connections, that time you can see the Given link. This confirms that the recommendation you have written is added on your profile and visible to your connections (or public, depends or your setting).

Hope this update will help you.

  • Thanks @serenesat. I am updating my question to respond. – Walrus the Cat May 12 '15 at 17:52
  • @WalrustheCat: Look at updated section of the answer. – serenesat May 12 '15 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.