0

I want to forward the RSS feed of a vBulletin Forum to Facebook. If the posting contains an image, it should be displayed within the facebook post.

So I used the Recipe:

  if [New feed item from http://example.com/feed]
then [Upload a photo from URL on myFacebookPage]

This recipe is active since a week. Although there have been new items, they didn't get forwarded to facebook. Next to the recipe there is the text:

created May 05, 2015 never run

If I configure the recipe to upload them without a photo, everything works. Why does this not work for photos?

Here is an example what my feed looks like:

<?xml version="1.0" encoding="UTF-8"?>
<rss xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:content="http://purl.org/rss/1.0/modules/content/" version="2.0">
    <channel>
        <title>bla</title>
        <link>https://example.com/</link>
        <description>Yep</description>
        <language>de</language>
        <lastBuildDate>Wed, 13 May 2015 11:00:38 GMT</lastBuildDate>
        <generator>vBulletin</generator>
        <ttl>15</ttl>
        <image>
            <url>https://example.com/misc/rss.png</url>
            <title>Here</title>
            <link>https://example.com/</link>
        </image>
        <item>
            <title><![CDATA[Bla]]></title>
            <link>https://example.com/threads/uniqueURL</link>
            <pubDate>Mon, 11 May 2015 18:32:11 GMT</pubDate>
            <description><![CDATA[ Some text and a graphic: https://example.com/someimage.png]]></description>
            <category domain="https://example.com/cat1">cat1</category>
            <dc:creator>Someone</dc:creator>
            <guid isPermaLink="true">https://example.com/threads/uniqueURL</guid>
        </item>
        <!-- More items -->
    </channel>
</rss>
| | | | | |
  • That is odd. I'm not sure that we'll be able to help you here. This looks like it might be a bug on IFTTT's part. I suggest you contact their support directly. In my experience they're pretty responsive. – ale May 13 '15 at 12:13
1

The action is never carried out because the RSS feed isn't recognized as creating a new entry by IFTTT. You have't included the feed URL so this can't be fully checked. This is almost certainly a problem with the feed. Here are some steps to try:

  • validate the feed's link
  • use a feed santizier's RSS instead and check this triggers
  • use the Maker channel or another trigger instead
  • make sure that the vBulletin forum is not password-protected or available only when logged in, if it is see if there is an option to get emails for each photo post, and use IFTTT's email trigger instead

The w3 feed validator gives warning: line 26, column 4: Missing atom:link with rel="self" instructions to fix

| | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.