2

It sounds strange, but I'm unable to sign up to Twitter.

When I try to use Google Chrome, the sign up form contains only name and e-mail fields. And even though all of them are filled-up and contain valid values (notice check-marks), I'm bumped with Please complete all required fields error every time, I click Sign Up:

enter image description here

When I'm using Opera, I'm able to see username additional field (but still no sign of password field), but I'm hitting the wall with the same error message, even though -- again -- all fields are correct:

enter image description here

When I try to use Internet Explorer, I can finally see all the four fields, but effect is exactly the same:

enter image description here

What am I missing? I know, how much stupidity is in this question, but... how should I sing up to Twitter?

BTW: In all my attempts (in all browsers), I'm trying to use my own e-mail and all the time it is the same, if that matters. When I tried to used some fake, probably not existing e-mail address, I managed to pass through this step. I closed web page after that, because -- quite naturally -- I want my Twitter account on my real e-mail, not on some fake one.

  • 1
    Are you sure you don't already have a twitter account? Try resetting your password first. If that doesn't work, maybe you could try registering with another e-mail address and after having successfully registered, change your e-mail. The first one (opera) could be a bug but could also be an A/B test. – viper Jun 9 '15 at 8:34
  • Yeap. The password reset form says, that they don't have such e-mail on records. Currently I'm further investigating this case. – trejder Jun 9 '15 at 8:37
3

This problem is directly linked to this question. I was trying to register a Twitter account, that contains .com in name (which is not allowed since recently).

There's a bug in Twitter, which causes to display error:

Please complete all required fields

and mark name field as having correct value. While it actually should mark it as invalid (because it contains .com part, prohibited) and should display correct error message. Like for example:

Account creation failed: Name must not contain URLs

Or something around that.

There's still, of course, an open question, when did they changed their rules (I managed to create an account containg .com in name about three months ago) and why do they limit domains prohibited in name to only a certain group (you can use .pl and probably many more ccTLDs in Twitter name)?

  • Had a similar problem today. Perhaps because my 'first name' was 'I'. – MastaBaba Nov 23 '17 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.