1

Posting this self-answered question because my friend seems to be the first to have discovered it.

I live in France and have a French credit card, but the first card on my account was a US card. The Play Store shows everything in dollars, but I want to pay in Euros. I already deleted the old credit card from my Google Wallet and I only have my French card now, and it still shows the wrong currency. Anyway, maybe I'm willing to pay the currency conversion fee.

The main problem is that after I add my card in Google Play for android, it shows me the same screen with the price of the song/app/movie with no "buy" button, and when I click "continue" I'm just selected to choose my card again.

1

I don't know why no error message is given. Pretty terrible. But when I fixed the currency problem, it also fixed this endless continue - choose-card loop, and let make an actual purchase. Yay!

Before reading how to fix this, note this weird stuff: There is no direct way to change the currency. And even after you change some settings that affect currency, Play store won't show the up-to-date currency until you actually start to buy something (but don't actually buy it). To get the rest of the app/website to start showing the new currency, you have to clear the cache -- applies to android app and web version of the Play store.

There are two things you need to do.

1) Change your Home Address in Google Wallet (this is a different setting than your billing address of the default credit card, and different from the "Address Book" which holds shipping addresses!)

Sign into Google Wallet at https://wallet.google.com/ and click the Settings icon in the top right corner. Use the desktop web version of Google Wallet. The android Wallet app does not let you change your home address as of this writing.

Click Edit next to the "Home Address" listed and update the address.

2) Make sure your default credit card has a billing address in a country whose currency is the one you want to see.

After doing step 1, click "Payment Methods" on the left, and add a new payment method with a billing address in the country that matches the currency you'd like to use.

Click "Set as default" next to this card.

3) Begin making a purchase but don't actually purchase anything, then clear the Play store cache.

  1. Open the Play Store and navigate to any item available for download.
  2. Click to begin a download until you reach the "Accept and buy" screen (no need to complete the purchase)
  3. Close the Play Store and clear data for the Google Play Store application (Settings > Apps > Google Play Store > Clear Data) or clear your browser cache
  4. Re-open the Play Store. You should now see the Play Store that matches your default payment method’s billing country.

Tip: if you're not sure if your settings are correct or if your cache isn't cleared, using an incognito window will tell. If it works in incognito but not otherwise, the problem is your cache. If it doesn't even work in incognito, go back to Wallet and check your settings.

Lastly, don't forget about calling Google Play support, where you can get help from someone who can actually see your account: https://support.google.com/googleplay/table/6068053?hl=en

Sources: https://productforums.google.com/forum/#!topic/play/QXdA_Q3V1o8 and others.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.