1

If I click on a link like https://books.google.it/books?id=_b8NAAAAQAAJ&pg=PA317&dq=%22dutch%20defence%22&hl=it&sa=X&ved=0CFMQ6AEwB2oVChMIlvGX3cb1xgIVAlkUCh0C-ApT#v=onepage&q=%22dutch%20defence%22&f=false , the page displays info in Italian, presumably because of query string containing hl=it. Apart from manually editing the URL to have hl=en, which feels like a hacky approach to me, how can I make it display in my default language?

  • 1
    Just an educated guess, so take it with a grain of salt, but I doubt that you can do this. The whole point of the URL parameter is to enforce its value. – Alex Jul 26 '15 at 16:48
  • Also, the page gets displayed in Italian also because the site is a regional one (i.e. .it). And you get redirected to it because of Google’s cookies you already have in your browser. – Alex Jul 26 '15 at 16:51
  • @Alex removing the parameter &hl=it makes the page be displayed in the user default language even if the local domain is a from a different country. – Rubén Jul 27 '15 at 18:40
1

Short answer

Remove &hl=it from the URL.

Explanation

The ht=it tells to the Google Books app to override the default language setting by using Italian.

The same apply to almost all the Google apps.

References

Meaning of Parameters in a Google Query - Google Operative System (Unofficial Blog)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.