1

I started a Google Group in June and then got busy with other things and haven't done anything with it since. It seems like I've lost ownership of the group and I don't know how to get it back. In the inbox of my group account, there was this email:

enter image description here

When I clicked on the "Accept this Invitation" button, I was told that the invitation had expired. Now I don't have ownership of the group anymore. How can I get it back, or at least create an all new group with the same name? I had only invited three members, so that's easy enough to recreate.

There was also another email I received:

enter image description here

I have permission to "visit" and "email" the group, but not "change settings" or "invite more users". If I try to do either of those things, I'm told that I don't have the permissions and need to contact an owner. But as far as I can tell, my group does not currently have an owner that has ownership privileges.

  • When a new group in Google Groups is created, an email message is sent to the account used to create it. Do you have that email message? – Rubén Aug 26 '15 at 0:47
  • @Rubén I think I did receive the message you're talking about. I've now edited my original question to include a snapshot of it. – Ruby Aug 26 '15 at 1:08
  • That is not the message that I'm referring to. Later I'll add more details. – Rubén Aug 26 '15 at 1:25
  • @Rubén I did receive two messages from them.. I've edited my question so as to include screen shots of both messages. – Ruby Aug 26 '15 at 2:14
0

Summary

At this time Google Groups have implemented features to prevent that a group be without at least one owner, so if you are sure that you have the owner role and can't access your group as owner, try one of the following:

  1. launch your browser in private browsing mode,
  2. sign out of your Google account and sign in again
  3. clear the cache and delete the cookies
  4. use another browser that you didn't use to access your Google account.

Content at the time that this answer was accepted


As LMcKin51- Google apps-Top Contributor said:

First of all, I'll need to make sure you are accessing your Groups with the correct email account. If your account is correct, have you asked the other owner if by any chances he deleted your ownership from the Group?

Also, have in mind that a Group always need to have an owner.

Let me know how it goes.

and if you using an non gmail.com account and if you haven't created a Google account for it create one here https://accounts.google.com/SignUpWithoutGmail then you be able to Manage your group.

If you can't recall the account you can try using the recovery tools that Google provides to remember the username https://www.google.com/accounts/recovery/forgotusername


I just tried to remove myself from a group, but I can't.

Attempt to remove the owner role from my own account
You cannot remove all the owners

Attempt to abandon the group Cannot remove sole owner

  • The group has never had any owner other than me. And I'm definitely trying to access it via the correct email account. When you say that a group always needs to have an owner, do you mean that it's not possible gor a Group to exist without an owner? (Since it seems that mine does.) Or do you mean something else? – Ruby Aug 26 '15 at 19:49
  • @DeliaRuby: Yes, I mean that is not possible to take out all the owners of a group, theoretically. – Rubén Aug 26 '15 at 20:14
  • I want to add an image, but can't do it through comments, so I will edit my question above. – Ruby Aug 26 '15 at 20:55
  • I tried from a different browser and everything worked fine. I think the problem must have been that I was logged in to more than one gmail account when I'd been trying from Firefox. So then when I switched to Safari (which I basically never use) I was starting from a clean slate -- no connection to my main gmail account (as opposed to the one created to own my group). So thanks for all your time and help! – Ruby Aug 26 '15 at 21:31
  • Be signed in to several accounts could be confusing :). I'm glad to know that now have access as owner to your group. – Rubén Aug 26 '15 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.