2

Let's say I want to find "John Mills" in Gmail. When I type in john into the contacts, John Mills' email doesn't come up because it's saved as "Mills, John". Because Gmail has stored a large number of "Mills" last names, when I type in "Mills", "Mills, John" doesn't come up either.

How do I solve this problem?

To clarify, search works when I use Google Contacts. I need help when I'm searching the name in the "To:" box in Gmail.

1
  • Have you tried searching for "john mills"?
    – ale
    Aug 30 '15 at 12:15
1

The easiest way will be to add "John Mills" and, most importantly, his email address, to your contacts. Then, when you search for "John Mills" his email address will be used as part of the search.

Although, to be honest, in my tests, searching for "John Mills" returns "Mills, John" without issue. Perhaps the key is that you need to use both first and last name.

2
  • Thanks so much! To clarify, search works when I use google contacts. I need help when I'm searching the name in the "To:" box in gmail. Sep 3 '15 at 17:35
  • @sony: My advice holds there, too. If I start composing a message and type someone's name they'll come up. It works best if they're in my contacts.
    – ale
    Sep 3 '15 at 18:22
1

Normally, a search for john should find all relevant matches in your contacts, that is, all contacts containing a word starting with "john" in any field. E.g. "John Mills", "Johnny Appleseed", "Elton John", "123 Johnson Lane", etc.

(I think Google Contacts expects names to be entered like "John Mills", not "Mills, John", but searching for "Mills" should work either way. Android Contacts has options to sort by last name and to display last name first. I don't see those in web contacts currently.)

But if you're using the new "Contacts Preview" instead of the older "Contacts" feature, then a search for mills will show some matches from your contacts along with random matches from Google+. The irrelevant matches crowd out the relevant ones if you have many "Mills" family members in your contacts!

One fix for that is to switch back to the old Contacts:

  1. On the left-hand tab, click More.
  2. Click Leave the Contacts preview.

Alternative: People report that typing your query (mills) then hitting Enter (or clicking the magnifying glass search icon) will get better search results than just typing the query and looking at instant search results. [I can't test it because I left the Contacts Preview.]

1
  • Thanks so much! To clarify, search works when I use google contacts. I need help when I'm searching the name in the "To:" box in gmail. Sep 3 '15 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.