Slack insists on telling me that

foo: joined #best-chat-room-yay

Is there a way to disable this?

  • I added an answer, but I'm curious if you ever found anything else related to the topic? :)
    – Squazz
    Commented Mar 7, 2016 at 15:15

3 Answers 3


UPDATE: It seems it's now possible

Not as it is at the moment, no, unfortunately.

One thing you can do, is to mute the channel.

notification preferences menu

If that is not an option, then you're out of luck. The last thing I heard about this was in august 2015, where this tweet was made by Slack on Twitter:

@SlackHQ: can we hide join/leave messages through global or channel settings?

@willimac not at the moment but we're glad to send your request over to our team!

I myself have been using this userstyle as I'm only using Slack for WordPress: https://userstyles.org/styles/106647/wordpress-slack-hide-join-leave. I don't know if this is something you will be able to modify or user for other use cases.

WordPress also links to this at their official page about Slack, so I'm guessing that there isn't an official solution out there yet :/


This has been possible for a while now: https://get.slack.help/hc/en-us/articles/115002695043-Manage-join-and-leave-messages-

  1. From your desktop, click your workspace name in the top left.
  2. Select Administration, then Workspace settings from the menu. *
  3. Scroll down to the Join & Leave Messages section and click Expand.
  4. Check or uncheck the box next to Show a message when people join or leave channels.
  5. Click Save

* only available to the administrators of the Workspace


You could open the dev tools (hit F12) and run this on the console:

setInterval(function(){ $('.message.joined').hide(); }, 1000);

This will hide the "joined" messages within 1 second after they appear. You could even create a bookmarklet with this code so all you have to do is click your bookmarklet to start the interval.

Yes it's hacky, but it should do the job until they add the option in the preferences.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.