2

When I am trying to search for an email address in Gmail, let's say starting with 'a', it always shows me a particular email account which was in my contact list a long time ago. Even after deleting the contact and the emails, it still appears in my search for auto-fill. This happens in any browser; so it is not the cache of the browser though I have cleared that as well. I even went to the Web and App activity and deleted all history, but it didn't help. How do I resolve this?

  • Possibly related: Remove contact from Gmail – ale Sep 16 '15 at 3:32
  • Thanks. I think I found the reason but I cannot resolve though. The contact is in the folder 'Directory' of my gmail Contacts. The option More when I open the contact in the gmail Directory is not accessible to me. May be this is because this is a gmail alias for a company. – cleanplay Sep 16 '15 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.