12

I'm trying to create an email signature in which I'd use the Unicode character 📞 as the 'phone icon. However, Gmail is transforming it into a huge image upon send, and I can't do anything about it.

Original: Transformed:

Transformation also happens if I save it as a draft and re-open the message, so that at least speeds up the "debugging" process.

I also tried using <style>.whatever:before{content:'\1f4de'}</style><span class="whatever">... during my numerous attempts to bypass it, but in that case it'll just strip the style tag.

Any ideas how I could disable the emoji transformation or to trick it into not transforming &#128222;?

5
  • I don't think that this issue is due to the way that Gmail Web UI displays content. Instead it's more likely to be related to your OS and browser. Commented Sep 19, 2015 at 16:10
  • 1
    I understand what you're saying, but that's not the case. Gmail is replacing &#128222; to <img goomoji="1f4de" style="margin:0 0.2ex;vertical-align:middle;max-height:24px" alt="πŸ“ž" src="https://mail.google.com/mail/e/1f4de">, which is a huge 24px image, and the phone number in the signature is supposed to be just 10px.
    – RoliSoft
    Commented Sep 20, 2015 at 5:05
  • 1
    Did you got any solution not based on images? That looks awful.
    – Cesar
    Commented Jan 20, 2016 at 23:53
  • 1
    Unfortunately no. I went with a different email signature as a result, without the icons.
    – RoliSoft
    Commented Jan 21, 2016 at 14:07
  • 2
    I am still looking for a better solution. You can try two things for now: (1) Embrace the google-imposed image -- using inspect-element in chrome-browser you can locate the html code corresponding to your unicode-phone that has been replaced as an image, simply change it's max-height setting to match the font size of the surrounding font. (2) Similar to the first one, but instead, delete the entire content img tag except alt="πŸ“ž" This will force it to be used as alt-text, the draw back is the ugly square around it and many browsers include a broken page, or "X" symbol in it.
    – Xzila
    Commented Jun 8, 2016 at 20:20

2 Answers 2

3

Short answer

To put a black phone in the Gmail signature instead of using unicode emojis use an image or a different character like βœ† (U+2706), dingbat telephone location sign.

Partial explanation.

Chrome Desktop for Windows doesn't support color emojis1, so it display black ones in some cases. By the other hand, and according to the OP, the new Gmail emoji support feature is changing unicode characters by its own version of hosted emojis. This also being done by others like Twitter and WordPress2.

TODO:

  1. Read and test http://www.unicode.org/help/display_problems.html
  2. Try the <span>, <font size="10"> <p style="font-size:20px"> tags to prevent Gmail change the unicode character by something like <img goomoji="1f4de" style="margin:0 0.2ex;vertical-align:middle;max-height:24px" alt="πŸ“ž" src="https://mail.google.com/mail/e/1f4de">

Remarks

Previous Comment

In relation to my comment to the question, the first time that I read this question I was using Windows 8.1 and Chrome stable channel. The phone character in the first line was displayed small and black.
Now I'm using a Chromebook with Chrome beta channel, the phone character in the first link is displayed a bit bigger and yellow.

The above is, as was mentioned at the top, because Windows and other old OS doesn't support color emojis so maybe avoiding that Gmail change the unicode character by an emoji will not prevent that the unicode character change in other than Windows OS.

Resourses

From http://classic.getemoji.com/

Copy and Paste Emojis πŸ‘ Classic

This is the classic version of Get Emoji, showing backward-compatible emojis that work in all Windows 7 browsers, older versions of Android, and on Chrome for Windows 7, 8, and 10. These emojis will show in black and white on older systems, but will be converted to color when viewed by a recipient with a system that supports color emoji. Switch to regular emoji to view all new emojis.

References

3

Try this way.

<img alt="πŸ“ž" src=""> or <img alt="&#128222;" src="">

It works for me.

1
  • This works, but for some reason does not render the unicode symbols in the same font as the body text. Still, perhaps the least-bad of all options given that Google has decided to be adversarial in this case.
    – MRule
    Commented Apr 12, 2022 at 8:15

Your Answer

By clicking β€œPost Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.