I installed a new OS and I added Google Chrome to it. Now whenever I search for something it searches in google.com.cy. I do not want to keep searching there; I want it to search in google.com. For example if I search something in the Google Chrome Omnibox, after it searches the wanted result it searches in google.com.cy. If I click a new tab it brings me again Google in region. I want to prevent this.

  • 1
    I assume you actually live in Cyprus.
    – ale
    Commented Sep 26, 2015 at 1:30
  • If you set Google to search from the .com domain, it will do so as long as you keep its cookies. As for the omnibox, you can change/customise the search engine used by Chrome from preferences.
    – Alex
    Commented Sep 26, 2015 at 5:54
  • Possibly related: How to force Google to not mind my location during search
    – ale
    Commented Sep 26, 2015 at 14:27

1 Answer 1


If you are using Google.com (not the Omnibox) to search, there are two ways to change the search settings:

  1. Visit the Google Preferences page and set the location to wherever you want.
  2. Search http://www.google.com/en instead of just Google.com

If you want to change your search location in the Omnibox then instead of pointing to Google.com in the search setting, use http://www.google.com/en, or whichever region you want.

  • @Tsunami: If this answer solved your problem, you should use the "checkmark" to "accept" this answer. This will act as a signpost to future readers. See more information in the help center.
    – ale
    Commented Sep 28, 2015 at 0:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.