9

At the top of Google Docs, there is a big banner labeled “Template Chooser” that fills half my laptop screen with templates and encouragements to create new documents. I have more than enough documents. How do I get rid of it so I can focus on the documents I have? I don’t need this new on-boarding experience.

4

Short answer

At this time the template banner can't be turned off. To find your documents just scroll down.

Note: Templates are only available in English.

Long answer

This feature was announced at the beginning of the 2015's northern school year1. The first thread on the Google Docs Help Forum about this was started on September 2 (CST)2.

Submit your feedback to the Google Docs team through the Menu button straight from the Docs, Sheets or Slides web apps, then click on Help & feedback and fill up the feedback form.

References

  • Thank all the heavens! I decided to submit feedback on this thing that has been an annoyance to me every time I land at the the various "home" pages of Docs and Sheets. They've scheduled it for removal "later in 2016." They've got six weeks to go. I also want to focus on the documents that I have but also I see templates for resumes, like 100% of the documents I create are not resumes. 1-2% are letters. None are reports. The template page is a total waste of space and hides from me the things I use Google Docs for. – dash-tom-bang Nov 18 '16 at 21:23
  • 1
    I think that you misunderstood what is scheduled for removal "later in 2016", it's the Google Drive template gallery at, drive.google.com/templates not the Google Documents template banner at docs.google.com – Rubén Nov 19 '16 at 21:08
1

You can try using ad block to block the element on the page. I do this, but because of the CSS, you still have the extra space (the whole toolbar + chooser has an explicit pixel height). Still better than that annoying chooser. If you want to go nuts, you can edit your browser stylesheet to include:

.docs-homescreen-material-bar-enabled .docs-homescreen-docs .docs-homescreen-fcc-inlinecontainer-pinned-contracted, .docs-homescreen-material-bar-enabled .docs-homescreen-docs .docs-homescreen-fcc-flex-contracting, .docs-homescreen-material-bar-enabled .docs-homescreen-docs .docs-homescreen-fcc-flex-contracted, .docs-homescreen-material-bar-enabled .docs-homescreen-docs .docs-homescreen-fcc-flex-unhiding { height: auto; }

Of course, it's also likely that Google changes these classes anyway.

1

I created a workaround.

Install the Stylebot Chrome extension.

Then add the style I created and shared, here http://stylebot.me/styles/12456

This is the code for the Stylebot extension

.docs-homescreen-template-wrapper {
    display: none ;
}
  • Thanks for sharing the workaround. Unfortunately some sites for sharing user code were used for malware distribution. I think that if you expose the code of your your user style and as bonus adds the links to chrome extension and the style you create will make your anwser a lot better. One advange of this approach is if the chrome extension, the the stylebot.me site or your style are down for any reason, the readers still will be able to use your solution. – Rubén Jan 6 '16 at 16:20
0

Found workaround for Chrome (also using extension). Install any extension that allows you to run custom JS on the page. I have installed JScript tricks https://chrome.google.com/webstore/detail/jscript-tricks/odialddippdmebbfbflcneemfdglimod

Then add the following snippet to options and turn on "Autostart". That will remove this template area on page loading.

window.addEventListener('load', function(){
  document.getElementsByClassName("docs-homescreen-template-container")[0].setAttributeNode(document.createAttribute("hidden"));  
}, false );

Here is screenshot for reference:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.