14

I have a Gmail account which is set to pull in emails from an old POP3 account. For various reasons, I need to keep doing this.

At least several times a day I will get the following email from "Gmail Team":

The message "something spammy" from Fake Company (fake@company.com) contained a virus or suspicious attachment. It was therefore not fetched from your account me@pop3account.com and has been left on the server.

Message ID:

If you wish to write to Fake Company, just click reply and send Fake Company a message.

Thanks,

The Gmail Team

It's great that they aren't fetching this email and I have absolutely no desire to go and find out what "Fake Company" are sending me, but it would be really nice if Gmail didn't keep telling me this.

Is there any way I can turn this message off?

10

You can't "turn this off" as far as I know, however, you can set up a filter that automatically archives, or even deletes these informative messages.

Personally, I archive all these messages and apply a label, so I can easily find them again if I really need to.

Gmail used to prefix the subject line with "Message left on server:" which made it easy to filter these messages based purely on the subject.

However, Gmail no longer does this (the subject is the same as the original spam email - which makes it harder to determine until you actually open the email! Why Google?). You can still filter on the From and Message Body fields:

  • From: mail-noreply@google.com
  • Includes the words: and has been left on the server or contained a virus or a suspicious attachment. It was therefore not fetched from your account (as mentioned in comments)
  • Skip the Inbox (Archive it) or Delete it
  • Although a good idea, this solution doesn't work since the subject line always matches that of the spam. I did however solve this by setting "from" to mail-noreply@google.com and "includes the words" to contained a virus or a suspicious attachment. It was therefore not fetched from your account. If you update your answer, I'll mark it as the best. – Richard Nov 25 '15 at 22:35
  • Sorry, yes you are right. Google changed this behaviour a few months back (in June 2015) for some strange reason!? It used to prefix the subject with "Message left on server:". Whilst I had created a new filter to fix this, I looked at my out of date filter when answering this question! I've updated my answer. – MrWhite Nov 25 '15 at 23:47
  • If only there was a way to delete the original email on the server which contains the virus, that would be perfect! We could've used the Gmail's awesome anti-virus to remove these spammy viruses. Anyone knows a way to achieve this? – David Refoua Sep 27 '16 at 1:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.