Using Google Maps with latest Chrome/Win10, two questions:

  1. How do I get to overhead satellite photo views? Currently I just have 'Earth' and 'Map'.

  2. How do I get to 'birds-eye' satellite photos views (photos taken from angles)? (Sorry, that might be the 'bing' term).

Details: I'm using maps.google.com with the latest Chrome/Win10 (as of 2015-Dec-8), logged into Google. I am looking to see actual satellite images. The only options are 'Map' and 'Earth' view. The Earth view is 3D rendered and looks like garbage, completely unusable (... like a Picasso nightmare, the screen is full of 3D blobs with weird geometry and textures..).

Similar question asked before, didn't see a solution:

Here were suggestions on previous posts:

  • Suggestion: "Hovering over the map icon in the top-right corner should reveal a satellite view icon"
  • No such icon exists. I hovered over every icon on the page.

  • Suggestion: "Click on question mark-icon on bottom-right"

  • No such icon exists.

  • Suggestion: "Click on Earth (bottom left corner)"

  • Brings up 'Earth' and 'Map', no 'Satellite' option.

  • Suggestion: "Google Maps may default to Lite mode for older browsers and operating systems"

  • Unfortunately I have the latest browser and operating system. Temporary solution may be to use the 'preview' link instead of going to maps.google.com.

  • Suggestion: "in the lower-right corner of the white box"..."tiny almost invisible down arrow" ... "click the sat icon"

  • No down arrow exists in any white boxes. Couldn't find any "sat" icon.

  • Suggestion: Use Bing.

  • (really?)


  • Two temporary solutions seem to be:
    • Use Bing. Unfortunately Bing's imagery is low resolution for this area and seems to be out of date, also I don't like the interface. These features used to be available at maps.google.com, are they gone for good?
    • I found a temporary alternative link that at least restores satellite imagery (no birds-eye though). Rather than "http://maps.google.com/", go to "https://www.google.com/maps/preview/?force=canvas". This disables 'Earth', but also disables other features, and I assume this link is temporary. Any better way?

2 Answers 2


I think I've figured this out!

  1. Go to the hamburger menu at the top left, choose "Earth". The left-side menu will disappear, and the 3D images view will appear.
  2. Go to the hamburger menu again. Under "Earth" there are now 2 items: 3D on and Labels on.
  3. Click 3D on. It will toggle 3D to off.
  4. ...
  5. Rejoice.

Upper left menu icon, then click 3D to turn 3D off or on. When off, appears to be the satellite mode.

Not the answer you're looking for? Browse other questions tagged or ask your own question.