32

I constantly get "Phone Not Connected" in Whatsapp Web. This issue is sporadic and resolves itself in the course of a few minutes. When I really want to send a message right now, I fix it myself by just tapping the WhatsApp app on my phone (iPhone) and then I can use WhatsApp Web again.

phone not connected

Now, let's see what "Learn more" has to suggest:

  • I do have a very stable and reliable internet connection on my PC and on my phone. I even keep my phone connected to Wifi while at home.
  • Of course I have the latest version of everything (Windows, Browser, iOS)
  • And I'm using my own Wifi, where there are no restrictions at all.

That's all what's on the FAQ page.

WhatsApp Web works most of the time, like I said. But regularly I get this message. What am I doing wrong?

migrated from superuser.com Dec 21 '15 at 8:35

This question came from our site for computer enthusiasts and power users.

11 Answers 11

13

On Android running Marshmallow, you'll want to disable doze for WhatsApp.

For stock Android, this link shows how to do that: http://www.greenbot.com/article/2993199/android/how-to-turn-off-doze-mode-for-specific-apps-in-android-marshmallow.html

On my LG phone, I went to settings -> General Tab at the top -> Battery & power saving -> Battery Usage

Scroll down till you see Battery Optimization and under that, tap 'Ignore optimizations'

Scroll down until you see WhatsApp and move the slider so it is on.

  • 5
    I have it on "not optimized" to exempt it from dozing. But still the web/desktop app won't connect unless I unlock my phone and open the Whatsapp app. – user643011 Mar 12 '17 at 17:21
  • Note 4, Android 7 Settings -> Battery -> Battery Usage -> ⠇-> Optimise battery usage Then from the drop down, select "All apps", find WhatsApp, and disable :) (It should then appear in the list of "Apps not optimised", just to be sure) – Martin Bartlett Apr 14 at 10:56
9

OK!

So I think I might have figured this out.

Step 1 - Go to settings on your iPhone
Step 2 - Go to Whatsapp (the app)
Step 3 - Enable Background App
Refresh

Voila!

Since I made this change, the annoying yellow pop up has not come back.

  • This worked for me. Note that with the current iOS I had to enable background updates at all and then specific for the app. – webDEVILopers Oct 9 '17 at 12:30
  • 1
    Does not work for me :-( iOS v11.3.1, WhatsApp v0.2.9229. – Bugs Bunny May 23 '18 at 21:51
6

I think this may be a problem with the App in a phone going to sleep mode, where the app can't communicate anymore with WhatsApp servers or your browser. It happens to me too in Android, and I also found people complaining about that in Windows Phone too. Since you mentioned iOS, I'm guessing you're using it with an Apple phone.

I have no proof for my theory, other than waking up the phone and getting the app running causes it to function again, just like you described.

I'm actually having this issue right now. My Android phone is connected to the charger in another room. It is connected to wifi (I can ping it) and the only thing is it is with screen off.

So, my guess is that Whatsapp have an issue when the phone enters sleep mode.

3

Another option (for those users with Android 6.0 or higher) is to go to Settings > Battery, but then press the option button and select "optimize battery usage". You can switch between "apps not optimized" and "all apps". Select the second one and turn on or off WhatsApp.

  • 1
    Whether I should select "Optimise" or "Don't optimise" option. Selecting either one of those doesn't make sense. – Lucky Dec 5 '16 at 9:27
  • 5
    I have it on "not optimized" to exempt it from dozing. But still the web/desktop app won't connect unless I unlock my phone and open the Whatsapp app. – user643011 Mar 12 '17 at 17:21
  • 1
    This does not resolve the problem – Stack Underflow May 3 '18 at 19:40
1

Had the same problem on Samsung Galaxy Note 3 looks like it works normally when I turned of "power saving".
It says that this mode stops background apps with using internet. But still how do you receive message if it kills its networking I don't know. Could be that it is just scoping for info about new packages without formally connecting what it does when you receive message.
That is just my guess.

1

on iOS, if you have pass code or touchID access, and the display goes in sleep, Whatzapp Web disconnect itself. But i noticed that, also if it shows the "disconnected" message, it wakes up when a new message arrive. It's strange.

  • That's how iOS multitasking (background tasks) work. Any app is allowed to a limited amount of time to work in background mode (with a maximum of 15 minutes, but variable in time). When receiving a push notification (which is an iOS feature rather than a WhatsApp one), the app will be allowed to fetch data in the background again (or "resetting" that time). The only real solution to disconnection on iOS is to actually disable the automatic screen locking. – Alejandro Iván Apr 24 '17 at 22:23
1

This happens on Android because by default because the OS is trying to optimize battery usage.

To fix this connectivity issue and allow WhatsApp to run fully in the background on Android 9 Pie:

  • Long press on the WhatsApp icon
  • Tap the circular "i" icon
  • Tap "Advanced"
  • Tap "Battery optimization"
  • Find WhatsApp in the application list, and switch to "Don't optimize"
  • 1
    For Samsung phones the battery option is in the first menu item but other than that this worked for me. Thanks. – ThaJay Jul 10 at 16:02
0

For iPhone, as long as the phone screen is not locked, web.whatsapp is connected.
For phone screen to not get locked

  • Open WhatsApp
  • Keep the phone connected to a charging cable (via USB connected to your PC)
0

I managed to solve the problem by disabling the option that minimizes battery usage when Wi-Fi is on. I have LG L70 with Android 4.4.2 on it.

  1. First, go to Settings > Networks
  2. Tap on Wi-Fi
  3. Tap on "More" key, next to the Home button
  4. Open Advanced Wi-Fi
  5. Scroll down until you find "Battery saving for Wi-Fi" option, and then uncheck it.

You can lock your phone after this and test if your WhatsApp Web works. I haven't experienced the problem since disabling the mentioned option.

  • 1
    I had this WiFi always on setting already enabled on the Galaxy S7 Android 7.0, I have WhatsApp on the doze exception list (not enabled for battery optimization) and still it won't connect often unless I unlock the phone and open WhatsApp first. – user643011 Mar 12 '17 at 17:29
0

Just figured out how to solve this issue on WP. Go to Settings > System > Battery > Battery usage by application > WhatsApp > "Always allow in background". Sorry if something is different I just translated from Brazilian Portuguese.

-3

Had the same issue. Was working with Cell Data disabled, only WiFi. WiFi was set to shut off in Sleep; changed it to keep WiFi on when plugged to power.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.