In Google Docs, I imported a Word document and converted it to a Google doc. The spell checker didn't recognize English words such as "Monday" and "February". I assume that the document isn't using English for the spell checker language.

How can this setting be changed in a Google Document?

It wasn't using local language settings. Maybe because it started life as a Word doc (speculation). If I go into the setting and change it to Francais (French), spell check complains about "Monday". Change it back back to English, spell check doesn't complain about "Monday". So the Language setting affects spell check.

  • 3
    Don't use comments to add additional information to your own posts. Instead edit them. Jan 22, 2016 at 20:52

3 Answers 3


As of this writing, to change the Language setting of a Google Doc, go to File > Language. In that menu, you can select a language such as "English (United States)" to get the spell checker to recognize English words.

  • 1
    You can set the default language for new docs by setting the language in your google account at myaccount.google.com. Go to: Personal Info > General preferences for the web > Language, and ensure the language you want to use by default is at the top of the list
    – Conan
    Nov 29, 2021 at 12:27

For Google Spreadsheets:

Click File > Spreadsheet settings.

Under "General," click the "Locale" and "Time zone" menus to change your settings.


At the moment the File > Language option is not available anymore for now so this is another solution.

The language in which the document appears and checks is dependent of the language of your browser. If your browser is in Dutch and you want to check English, you can solve that by changing the language of your browser.

You can do this as follow:

  • Open the Docs, Sheets, or Slides home screen.
  • Click the Menu button in the top-left corner of your screen
  • Click the Settings icon
  • On the Settings page, click the drop-down menu next to Language
  • Select the language you want to use.
  • Click Save
  • 3
    "At the moment the File > Language option is not available anymore" - are you sure? I still have that menu item: imgur.com/a/cfOmm Sep 5, 2017 at 11:55
  • Well, my Brave browser is in English, but I still see Google Docs in Dutch.
    – SalahAdDin
    Aug 29, 2023 at 13:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.