63

Is there a setting or YouTube option, or maybe even a browser plugin, that allows you to disable video annotations for good?

I want to be able to switch them off permanently.

  • Just to add, the selected answer below does work but only temporarily. It's possibly a bug with YouTube (which I have reported) but it has been an issue for a while so I don't know when/if it will be fixed. – DisgruntledGoat Nov 7 '11 at 20:52
48

The option is found in the Account Playback settings:

  1. Click your profile picture and then YouTube settings
  2. Click Playback
  3. De-select Show annotations on videos
  4. Click Save
  • 6
    Here's the link: youtube.com/account_playback – Tim Büthe Oct 21 '13 at 21:01
  • 4
    Despite having this box unchecked, YouTube still seems to happily show all the annotations by default. I've had them disabled for years, and some YouTube update in the past year seems to have caused it to be ignored. – Jason C May 25 '14 at 7:15
  • Doesn't work... – Your Majesty May 25 '14 at 21:41
  • 1
    It works for me. – NoNameProvided Sep 11 '15 at 13:47
  • 1
    You should make it clear that this is NOT actually permanent. Annotations ALWAYS get turned back on some time later, no matter how many times you "permanently" turn them off in settings. – DisgruntledGoat Jun 11 '16 at 15:36
14

If you're like me and you don't want to help Google collect even more personal information about you by creating an account, you can still disable these annotations using an ad blocking extension that supports Adblock Plus-compatible filters and the following rule :

||youtube.com/annotations_
  • if I could +1 you 1000 times, i would!! – hassan789 May 24 '15 at 3:48
  • This is the only thing that works for me now – Raystafarian Jun 6 '16 at 9:00
  • This works without needing to log in to YouTube, wonderful! – Esteis Sep 28 '16 at 11:55
  • For me, the "account playback settings" method worked even on embedded videos on 3rd party websites in Safari, but stopped working on other sites than youtube.com when I switched to Chrome. This took care of that. – Andreas Sep 27 '18 at 13:13

protected by Community Jul 5 '13 at 19:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.