4

I would like to have my primary language (English) as the main language in Google Searches. I know the thread Setting Google results to stay in a language, regardless of location but addresses like http://www.google.com/en are redirected wrongly. So I would like to prevent all together some languages because they are used wrongly because I have visited such locations sometimes in my past. Secondary languages ar the following languages in Fig. 1

Fig. 1 Secondary languages in settings, Fig. 2 Search results, Fig. 3 Settings

enter image description here enter image description here enter image description here

I need to stay many days per month in Latvia; and many other countries per month. However, for some reason, Google wants to show me everything in Latvian, although I cannot speak or read it. I feel such a behaviour disturbing. I have went through all the language helps of Google, like here; contacted them unsuccessfully about the case but now also in their official Google Search Forum here. I have seen this behaviour now one year in Google search; here the left-hand-side bar of the Google search after searching "metso kirjasto" in Fig. 2 where the extraction contains .

  • Finnish (heading)
  • Latvian (most of the parts)
  • Swedish (Biblioteka)
  • ...

The situation feels more disturbing when Google messes up things with many languages; etc putting here Finnish, Latvian and Swedish together. It would be ok for me if there was no Latvian.

Search

Searching gives me these parameters in the address bar

  • https://www.google.lv/?
  • gws_rd=cr%2Cssl&
  • ei=Ns4PV7OAJebt6QTowrPgCw&
  • pli=1# - unknown parameter for instance here about What does &pli=1 parameter (and others) do?
  • q=metso+kirjasto

Search with the extension Don't track me Google

You see pli parameter is gone but the option safe=off as a new one

  • https://www.google.lv/?
  • gws_rd=cr,ssl& - google web server redirection country referred and ssl
  • ei=_9APV9D4LIXN6QTSyaToCg#safe=off& - time of execution and security off
  • q=metso+kirjasto

Language still stays in Latvian. The problem does not seem to be in gws_rd=cr,ssl& because google.com/ncr returns the output also in Latvian.

Search google.com/ncr

Output still in Latvian, like the screenshot above.

Settings

Settings in Fig. 3 where no Latvian. I have similar settings or only English in other OSes and systems too.

I have removed all my cookies, but it does not solve the problem.

I logged out Stackexchange in all devices. The google search "metso kirjasto" returns still the output as described above with most Latvian content.

No VPN.

Hypothesis about the Problem

I cleared all cookies. I searched "metso kirjasto" and everything was in English. I now login to Stackexchange with two-step login. I do again the Google Search "metso kirjasto". Everything is now like described above: Latvian mesh with Finnish and Swedish. I think Google's login system is somehow conflicting here. This is not apparently related to third-party cookies because I disabled them but I see the same behaviour still.

I opened a thread about the issue here too because the problem is still there.

Hardware: Chromebook 1, Chromebook 2, Asus Zenbook UX303UB
OS: Chrome OS, Windows 10 and all latest distros, OS X all latest versions, Linux Debian 8.5 - 8.7
Internet browsers: Google Chrome 56.x - 57.x, Firefox, Opera, Safari

  • Make sure your browser’s language settings are also set to English as the primary language. – Alex Feb 28 '16 at 7:28
  • @Alex I have English as my primary language in all browsers of mine. – Léo Léopold Hertz 준영 Feb 28 '16 at 7:30
  • Strange. It could be just a cookies issue then. Have you tried removing all of Google’s cookies and see if it still behaves like this? – Alex Feb 28 '16 at 7:33
  • @Alex Cookies are not the problem. Cleared them and problem still coming. – Léo Léopold Hertz 준영 Feb 28 '16 at 7:36
  • 1
    Maybe there are failures on the Google side. Did you already reported this in the Google Search help forum? – Rubén Apr 14 '16 at 20:28
1

Using Google while being signed out will ignore account settings. If are signed in and your main language is not used in www.google.com try

  1. To clear out the cache and cookies
  2. Go to http://www.google.com
  3. Sign in

Now the Google's home page should be displayed in your option for your account´s main language.

If the above doesn't work for any reason, a way to "force" that the Google's homepage be shown in English is to include the URL parameter hl=en. In the case of Google (aka Google Search) try

http://www.google.com/search?hl=en

For other languages, instead of en use the proper language code (en-uk for United Kingdom English, es-419 for Latin American Spanish, es for Spain Spanish, etc.)

  • The above settings do not work. I am using two-step verification. Those other variants, I do know, but find them difficult in real life. – Léo Léopold Hertz 준영 Apr 13 '16 at 19:03
  • That is weird. Add more details to the question like the URL in the omnibox / address bar. – Rubén Apr 14 '16 at 11:08
  • Which url do you want? You can choose just google.com and it always go to the language where my IP address is. – Léo Léopold Hertz 준영 Apr 14 '16 at 14:35
  • You could add the URL of the source of the screenshots in the question. Usually Google redirects users from a web search result page to another URL including several parameters. See the following question for further details: webapps.stackexchange.com/questions/22291/…. The same could happen with other Google services too. – Rubén Apr 14 '16 at 15:56
  • I think this is the problem of the source gws_rd=cr,ssl&. Google always choose country referred option for me although I do not want it. – Léo Léopold Hertz 준영 Apr 14 '16 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.