1

We have a couple of fields that we don't want to display on the form, but will be used by back-end administrators to add extra bits of data to those hidden fields. We need to be able to include the hidden fields' data in a confirmation email whenever those hidden fields are updated/edited by an admin.

How can we do this? In my testing so far, I don't see a way to accomplish this without making the fields visible, which we don't want to do.

1

Here is one way to accomplish this in Cognito Forms:

  1. Add your internal fields and mark them as Show This Field = Internally to ensure they only appear when managing entries.
  2. Add a calculation field, whose calculated value is the value of the internal field you want to include in the confirmation emails.
  3. Make these read-only calculation fields only appear when they have a value, using Show This Field - When.

Using this approach your confirmation emails will only show these values when they have been set. Furthermore, if you allow your customers to edit their submitted entries using secure edit links, these fields will also appear, but will be read only.

  • OK, this worked for one of the fields, but not the other. The field that uses radio buttons does show the correct value in the confirmation email. The other field is a text field, in which the form admin will be inputting a number. But... the confirmation email just shows "True" for this field, instead of the actual input value of the field... which I guess is maybe because this should be a number field instead of a text field...? – Steve Mar 17 '16 at 19:19
  • Make sure the Type of the Calculation field matches the type you are expecting to show. It sounds like the calculation may be set to Yes/No. – Jamie Thomas Mar 17 '16 at 19:44
  • OK, sort of got it working, except for the fact that in the confirmation email, the number value shows as "444.00" -- we need to omit any decimal values, should be "444." Any ideas? I've tried setting this field type to both "integer" and "decimal" but it displays decimals either way. – Steve Mar 17 '16 at 19:58
  • Just change the calculation type to Text. That should do the trick. – Jamie Thomas Mar 18 '16 at 0:34
  • OK, that worked. Thanks. I really appreciate your help. – Steve Mar 18 '16 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.