0

We are doing an Office 365 pilot using shared domains/internal relay following Microsoft's instructions here: https://support.office.com/en-us/article/Pilot-Office-365-with-a-few-email-addresses-on-your-custom-domain-39cee536-6a03-40cf-b9c1-f301bb6001d7

Currently we have internal relay set up and our on-premises Exchange server is forwarding for a couple users, e.g. bob@company.com forwards to bob@company.onmicrosoft.com and appears to Bob as if he received it at bob@company.com. However, when Bob replies to emails, his recipients are getting it from bob@company.onmicrosoft.com. Since we've set up SPF, there shouldn't be a spam issue sending as the domain.

We've tried setting Email Address Format in Email Address Policy, but it shows as "unapplied" and seems to have no affect.

We've also done everything we can to complete setup except actually change the MX record, which we can't do.

How can we configure Office 365 to send emails on behalf of @company.com?

  • I think that managing an email system is out of the scope of this Web Applications but it could be on topic on Server Fault. – Rubén Mar 22 '16 at 18:58
  • I could see posting it to SuperUser, but not ServerFault. It's all changing settings in a GUI and the product is a SaaS hosted by Microsoft. The on-premises Exchange server is just mentioned for context. – Michael Mar 22 '16 at 21:44
  • At this time there are 295 questions in Server Fault with the tag microsoft-office-365. Here there are only 3 questions with the office-365 besides this site is focused on Power Users (in this case using Outlook online) rather than in administrators and systems managers (setting up DNS records, email routing, etc). – Rubén Mar 23 '16 at 13:55
  • Okay, that's fair. I'll ask there next time. – Michael Mar 23 '16 at 15:43
1

The answer is that the one user that was used to create the Office 365 account needed to have its login updated - it was still set to @company.onmicrosoft.com and updating it to @company.com, logging out and logging in fixed the issue. All future accounts created won't have this issue as they'll be @company.com by default.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.