I'm trying to run a query (IMPORTRANGE) formula in a new Google sheet. The data I'm trying to load is from another sheet. The source sheet contains 6,000 rows and 12 columns. I tried:

=QUERY(IMPORTRANGE("SHEET_KEY","Sheet1!A:C"),"select Col1")

The result is #REF! and when I hover over the cell there is no additional information.

I also tried the IMPORTRANGE formula separately and it's loading the data correctly. I tried the exact same query in a new tab in the source sheet:

=QUERY(Sheet1!A:C,"select A")

and the data was loaded successfully, however I need to run the query formula in a new Google sheet.

  • 1
    Have you tried to make ImportRange formula only? IMPORTRANGE("SHEET_KEY","Sheet1!A:C") Apr 15, 2016 at 13:44
  • 1
    Also, hovering over the cell with an error should give a bit more information.
    – user79865
    Apr 15, 2016 at 17:23
  • No additional information on hover; importrange works separately
    – Bogdan
    Apr 16, 2016 at 4:11

1 Answer 1


I'm not sure, but it could be some sort of glich.

This post may help you.

I had similiar problems. I tried doing this:

  1. refreshing page
  2. changing range in the formula to force it recalculate: "Sheet1!A:C""Sheet1!A1:C6000"
  3. Also found smart way to make it with iferror: iferror(IMPORTRANGE("SHEET_KEY","Sheet1!A:C"))

If this won't help, please give example file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.