In normal browsing mode, when I search for "pimp scroll bar html", I get no results:


However on Incognito mode (for Google Chrome), suddenly I get results: incognito

I disabled all my extensions, and yet the problem is still there. Why does this happen?

EDIT: I tried logging out of my google account, and for some BIZZARE reason, now the search works properly. Why would me being logged in stop the searches from appearing?

2 Answers 2


This is a really silly situation.

The answer really only deserves a single line: I had safe search turned on.

Somehow I took a screenshot of that, and didn't notice.

(In the 0.0001% chance somebody needs to know, you can just turn safe search off by clicking the gear at the top right of the page (under your account picture)).

  • 2
    And thanks to your silly situation, the next time someone has it and googles what to do, they immediately find out how silly it is :)
    – djechlin
    Commented Apr 17, 2016 at 14:27
  • 1
    How silly am I? I'm really silly. That dude "I" should stop being silly. Commented Apr 17, 2016 at 20:37
  • I thought they got rid of safe search and made it so that "adult content" was always filtered unless explicitly stated in the search query?
    – Celeritas
    Commented Apr 18, 2016 at 4:01

That's not the only case.

It happens for that reason or even if you participate to the program "custom ads".

Nonetheless, Google (Alphabet?) has different servers and different domains around the globe.

Try this https://www.google.com/webhp?source=desktop&devloc=0&gws_rd=cr

or this https://www.google.com/imghp?hl=en

Any difference?

Of course there are, because we deleted the parameter "&ei=your-crypted-personal-identifier" from the address (and a few other things). Websites are really "naked software" and you can interact with them easily; this will change their behavior, thus, you can have different results based on many factors.

Not the answer you're looking for? Browse other questions tagged or ask your own question.